Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#330 closed defect (worksforme)

have diff tools - svn diff works fine -- diff command line works fine -- diff view in trac doesn't work

Reported by: edunne@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/changeset view Version: 0.6.1
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

I have installed the gnu diff tools, version - 2.8.1-3 I have apache 2.0.49 windows xp all the latest patches etc. I have the added the location of the diff tools installation to the path variable Diff tools works fine from the command line. svn diff works fine from the command line (as well as from tortoise svn)

Eveything seems to running just fine with trac, except for the diff view. This is probably just a config error, but I've looked at the mailing list and faq and tried all the suggested fixes. So I'll risk getting flamed, as long as someone sends me fix for the issue.

Attachments (0)

Change History (4)

comment:1 by johan@…, 16 years ago

I had this, or similar, problem, until I used the printenv.pl cgi-example and noticed that the PATH variable hadn't been updated in apache, so trac couln't find diff.exe. Restart of the apache service didn't help. Had to reboot to get apache to notice that PATH had changed.

comment:2 by daniel, 16 years ago

Resolution: worksforme
Status: newclosed

No risk for flamage. :)

I'm however unable to reproduce this on ms windows. Let me know if you got it working and found the problem. :-)

comment:3 by zackangelo@…, 15 years ago

Resolution: worksforme
Status: closedreopened

I'm having this same problem. When I run Apache from the command line, it locates diff.exe fine. When I run it as a service, it has trouble. I've tried copying diff.exe into the apache bin and modules directory, no luck. Any ideas?

comment:4 by Christopher Lenz, 15 years ago

Component: browserchangeset view
Description: modified (diff)
Resolution: worksforme
Status: reopenedclosed

Please see the FAQ.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.