Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#725 closed defect (duplicate)

Missing diff functionality

Reported by: swillison@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/changeset view Version: 0.7.1
Severity: normal Keywords: diff
Cc: Branch:
Release Notes:
API Changes:

Description

Our install of Trac 0.7.1 is missing diff functionality in the TracChangeset view - the diffs aren't showing up at all. I dug around a bit and discovered that the Diff functionality is provided by a file called Diff.py, which was nowhere to be found in the site-package/trac directory. I downloaded a fresh 0.7.1 tarball (from http://ftp.edgewall.com/pub/trac/trac-0.7.1.tar.gz ) and discovered that Diff.py isn't included in the distribution! Is this a mistake, or has that functionality been rolled out of the release version?

Attachments (1)

trac-screenshot.gif (44.4 KB ) - added by anonymous 15 years ago.
Screenshot of changeset view with missing diffs

Download all attachments as: .zip

Change History (7)

comment:1 by Christopher Lenz, 15 years ago

Component: generalchangeset view
Keywords: diff added
Resolution: invalid
Status: newclosed

Diff.py was added in the development stream after the 0.7 stream was branched out. The functionality in the 0.7 stream is provided by Changeset.py.

There have been reports about diff display not working on Windows. See #511, for example. If you're not on Windows, or can provide more details, reopen this ticket.

comment:2 by anonymous, 15 years ago

Resolution: invalid
Status: closedreopened

We're running Trac on Red Hat ES Linux, with subversion 1.0.6 (and I'm viewing it using Firefox on OS X). I tried changing all instances of "-u" to "-U" in the Changeset.py file based on the patch in #670 but it didn't fix the issue.

by anonymous, 15 years ago

Attachment: trac-screenshot.gif added

Screenshot of changeset view with missing diffs

comment:3 by Christopher Lenz, 15 years ago

Summary: Missing Diff.py (and diff functionality) in Trac 0.7.1Missing diff functionality

Then let's change the summary. Note that #670 only applies to the devel version (not 0.7.1) as far as I know.

comment:4 by jacob@…, 15 years ago

The fix is extremely simple: in svn.fs.FileDiff.get_pipe, line 116, the "diff" command is popen'd. For whatever reason, out installation wasn't finding that binary, so I hardcoded "/usr/bin/diff".

This could probably be fixed by a setting for binary search paths within trac itself… although I'm not exactly sure how popen uses search paths.

comment:5 by anonymous, 15 years ago

It might be good to have trac throw a warning (either on screen or in the error log) if it can't find the diff program, rather than just failing silently.

comment:6 by daniel, 15 years ago

Resolution: duplicate
Status: reopenedclosed

This is actually a dupe of #511… Redirecting discussions there.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.