Edgewall Software
Modify

Opened 15 years ago

Last modified 6 years ago

#4778 new enhancement

simplified wikification of svn log messages

Reported by: Sergei Haller <sergei@…> Owned by:
Priority: normal Milestone: next-major-releases
Component: wiki system Version: devel
Severity: normal Keywords: formatter
Cc: rbu@…, lists@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Is it possible to simplify the wikification of svn log messages? The problem I get is if we have some math content (like

x^5+x^4+x

which will show like x5+x4+x. There are some other things as well, which we don't actually need in or project, as the log messages are and will always be plain text. The only thing I'd like to keep is the recognition of revision numbers in the log messages with the appropriate links.

Is it hard to achieve this? (Would be ok if it is in the source, i.e. not configurable by admin/user)

Thanks.

Attachments (2)

format.patch (599 bytes ) - added by Sergei Haller <sergei@…> 15 years ago.
short-mes.patch (684 bytes ) - added by Sergei Haller <sergei@…> 15 years ago.
somewhat related. fixes shorten_line call in revision log if wiki_format_messages is disabled.

Download all attachments as: .zip

Change History (18)

comment:1 by Sergei Haller <sergei@…>, 15 years ago

Type: defectenhancement

comment:2 by Sergei Haller <sergei@…>, 15 years ago

well, I found the place (template/changeset) and replaced

-              ${wiki_to_html(context, changeset.message, escape_newlines=True)}
+              <pre>${changeset.message}</pre>

is there any easy way to parse the message for revision numbers and convert them to links?

comment:3 by Christian Boos, 15 years ago

Component: changeset viewwiki
Description: modified (diff)
Keywords: formatter added
Milestone: 0.11
Owner: changed from Christian Boos to Jonas Borgström
Summary: wikification of svn log messagessimplified wikification of svn log messages

There's currently a TracIni#changeset-section option for that (wiki_format_messages).

Also, I'm in the process of refactoring the Wiki engine. I think it should be possible to create a "TracLinks only" formatter, so that only things like tickets and changesets links get formatted.

by Sergei Haller <sergei@…>, 15 years ago

Attachment: format.patch added

in reply to:  3 ; comment:4 by Sergei Haller <sergei@…>, 15 years ago

Replying to cboos:

There's currently a TracIni#changeset-section option for that (wiki_format_messages).

thanks, I must have overseen that option. Though it doesn't respect line breaks. This is easily fixed (see attached patch)

Also, I'm in the process of refactoring the Wiki engine. I think it should be possible to create a "TracLinks only" formatter, so that only things like tickets and changesets links get formatted.

that'd be great, too.

in reply to:  4 comment:5 by Christian Boos, 15 years ago

Replying to Sergei Haller <sergei@sergei-haller.de>:

Replying to cboos:

There's currently a TracIni#changeset-section option for that (wiki_format_messages).

thanks, I must have overseen that option. Though it doesn't respect line breaks. This is easily fixed (see attached patch)

thanks, applied in r4799.

by Sergei Haller <sergei@…>, 15 years ago

Attachment: short-mes.patch added

somewhat related. fixes shorten_line call in revision log if wiki_format_messages is disabled.

comment:6 by Christian Boos, 15 years ago

Owner: changed from Jonas Borgström to Christian Boos

hm, btw, I didn't notice attachment:short-mes.patch but I did notice the columns full of shorten_line(message) → r4800 ;-)

comment:7 by Christian Boos, 15 years ago

In #3203, there's the idea to specifically disable one kind of link resolver (the r… style changeset links).

comment:8 by Christian Boos, 15 years ago

#4944 was closed as duplicate (emphasis was put there on the need to respect whitespace).

comment:9 by Christian Boos, 14 years ago

Milestone: 0.110.12

WikiEngine refactoring and related fixes postponed.

comment:10 by Alexander@…, 14 years ago

Is the "TracLinks only" formatter already implemented? I am new to Trac and do not know how to interpret the message "milestone changed from 0.11 to 0.12" in this thread. The Trac instance I am a user of is still based on 0.10.3, but if I knew there was a feature like "TracLinks only", I might be able to convince the admin to upgrade to a newer version. The problem I had with the Wiki formatter is described in #6510.

comment:11 by Christian Boos, 14 years ago

It simply means this feature is on the TODO list for 0.12.

comment:12 by rbu@…, 12 years ago

Cc: rbu@… added

adding to cc (this text is needed to not trigger the spam detection, unfortunately)

comment:13 by Christian Boos, 11 years ago

Severity: normalminor

comment:14 by Christian Boos, 11 years ago

Severity: minornormal

#3591 was closed as duplicate of this ticket.

comment:15 by Thijs Triemstra <lists@…>, 11 years ago

Cc: lists@… added

Could be useful for the 'description' field in the csv export as well.

comment:16 by Ryan J Ollos, 6 years ago

Owner: Christian Boos removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.