Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#4135 closed defect (fixed)

None of the links are currently working for me.

Reported by: mncwatson@… Owned by: Christian Boos
Priority: normal Milestone: 0.11
Component: general Version: 0.10
Severity: trivial Keywords: extensionoption
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Python traceback Traceback (most recent call last):

File "/var/lib/python-support/python2.4/trac/web/main.py", line 356, in dispatch_request

dispatcher.dispatch(req)

File "/var/lib/python-support/python2.4/trac/web/main.py", line 168, in dispatch

chosen_handler = self.default_handler

File "/var/lib/python-support/python2.4/trac/config.py", line 377, in get

raise AttributeError('Cannot find an implementation of the "%s" '

AttributeError: Cannot find an implementation of the "IRequestHandler" interface named "TagsWikiModule". Please update the option trac.default_handler in trac.ini.


Powered by Trac 0.10

By Edgewall Software. Visit the Trac open source project at http://trac.edgewall.com/

Attachments (0)

Change History (4)

comment:1 by Noah Kantrowitz (coderanger) <coderanger@…>, 16 years ago

Please review the TracTags install instructions and ensure you enabled the correct modules. As the tags website is offline, if this doesn't fix it you can either email one of the lists or file a ticket on Trac-Hacks.

I would propose a wontfix for this ticket.

comment:2 by Christian Boos, 16 years ago

Milestone: 0.11
Owner: changed from Jonas Borgström to Christian Boos
Severity: normaltrivial

Maybe with could also change:

"Please update the option trac.default_handler in trac.ini."

to:

"Please update the option trac.default_handler or enable the corresponding module in trac.ini"

in order to avoid some hair pulling, as this exception is triggered because the user updated his trac.default_handler option…

But other than that, I'd have agreed to the wontfix (or even notourproblem ;) )

comment:3 by anonymous, 15 years ago

Keywords: extensionoption added
Resolution: fixed
Status: newclosed

Error message improved in r4770.

comment:4 by sid, 14 years ago

#7171 was marked as duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.