Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#7171 closed defect (duplicate)

AttributeError: Cannot find an implementation of the "IRequestHandler" interface named "TagsWikiModule". Please update the option trac.default_handler in trac.ini.

Reported by: kris.wallsmith@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: devel
Severity: normal Keywords: tags
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

This error occurs when accessing / but not when accessing /wiki/. Kris

How to Reproduce

While doing a GET operation on /, Trac issued an internal error.

(please provide additional details here)

User Agent was: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18

System Information

Trac 0.11dev-r6914
Python 2.4.3 (#1, Mar 14 2007, 18:51:08)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
setuptools 0.6c6
SQLite 3.3.6
pysqlite 2.3.3
Genshi 0.5dev-r845
mod_python 3.2.8
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6914-py2.4.egg/trac/web/main.py", line 417, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6914-py2.4.egg/trac/web/main.py", line 169, in dispatch
    chosen_handler = self.default_handler
  File "/usr/lib/python2.4/site-packages/Trac-0.11dev_r6914-py2.4.egg/trac/config.py", line 462, in __get__
    raise AttributeError('Cannot find an implementation of the "%s" '
AttributeError: Cannot find an implementation of the "IRequestHandler" interface named "TagsWikiModule".  Please update the option trac.default_handler in trac.ini.

Attachments (0)

Change History (3)

comment:1 by kris.wallsmith@…, 14 years ago

The error went away after I deleted the trac.default_handler line in trac.ini. The error also occurs when that value is set to wiki.

comment:2 by Tim Hatch, 14 years ago

The default should be WikiModule, not just wiki. It looks like you're trying to use the tags plugin. Is it enabled?

comment:3 by sid, 14 years ago

Keywords: tags added
Resolution: duplicate
Status: newclosed

Duplicate of #4135. This is a misconfiguration of the Tags plugin. There is also th:#1158 that discusses the same issue that might be of interest.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.