Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#3860 closed defect (wontfix)

Snoopy (command logger) and Trac

Reported by: vamancini [ at ] sbcglobal.net Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: none
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm not sure if this should be a bug/defect, but it is definitely worth noting that snoopy and trac do not like each other. What snoopy is (from http://sourceforge.net/project/showfiles.php?group_id=9226):

Snoopy is designed to aid the task of a sysadmin by providing 
a log of commands executed. Snoopy is completely transparent to 
the user and applications. It is linked into programs to provide
a wrapper around calls to execve(). Logging is done via syslogd.

For one of our websites at DePaul University, we have apache 2.0.55, python 2.3.5, trac 0.9.6, and debian sarge (kernel 2.4.x). By adding snoopy, trac would fail. In the apache logs, one can see that every time an attempt was made to access trac, an apache child process would produce a segmentation fault similar to this:

[Sun Oct 01 02:06:55 2006] [notice] child pid 14810 exit signal 
Segmentation fault (11)

Running trac-admin stand-alone while snoopy was running also produced segmentation faults. Once snoopy was removed and apache restarted, trac started to work again. This is easily reproducible.

Thanks,
Vince

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 15 years ago

I don't think Trac has much to do with this… have you tried with other Python scripts? Is Trac the only one triggering the issue? If this seems to be the case, try again with a simple python script using the Subversion bindings, I wouldn't be surprised if this also fails…

comment:2 by Christian Boos, 14 years ago

Resolution: wontfix
Status: newclosed

Well, I don't see what we could do here.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.