Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#3861 closed defect (duplicate)

Browse source causes "oops" and traceback on a SubversionException

Reported by: HawK Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.6
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/fcgi_frontend.py", line 40, in _handler
    dispatch_request(req.path_info, req, env)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 102, in process_request
    self._render_directory(req, repos, node, rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/browser.py", line 134, in _render_directory
    changes = get_changes(self.env, repos, [i['rev'] for i in info])
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/web_ui/util.py", line 33, in get_changes
    changeset = repos.get_changeset(rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 42, in get_changeset
    self.sync()
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 82, in sync
    changeset = self.repos.get_changeset(current_rev)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 251, in get_changeset
    self.fs_ptr, self.pool)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 467, in __init__
    message = self._get_prop(core.SVN_PROP_REVISION_LOG)
  File "/usr/local/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 534, in _get_prop
    return fs.revision_prop(self.fs_ptr, self.rev, name, self.pool())
  File "/usr/local/lib/python2.4/site-packages/libsvn/fs.py", line 576, in svn_fs_revision_prop
    return apply(_fs.svn_fs_revision_prop, args)
SubversionException: ('No such revision 35', 160006)

my trac: https://opensvn.csie.org/traccgi/l2jjenova/browser

Attachments (0)

Change History (3)

comment:1 by Emmanuel Blot, 13 years ago

Description: modified (diff)
Version: 0.100.9.6

Watch out the Trac release: http://opensvn.csie.org uses 0.9.6, not 0.10

comment:2 by anonymous, 13 years ago

Summary: https://opensvn.csie.org/traccgi/l2jjenova/browserBrowse source causes "oops" and traceback on a SubversionException

At first glance, this appears to be a Subversion problem. These might help:

http://svn.haxx.se/users/archive-2005-08/0347.shtml http://svn.haxx.se/users/archive-2004-01/0392.shtml

comment:3 by Christian Boos, 13 years ago

Resolution: duplicate
Status: newclosed

The problem is still there, but that Trac is running release 0.10.1, and this kind of error is only completely fixed in 0.10.3.

There are a lot of similar tickets for 0.9.x with this kind of error (e.g. #3773).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.