Edgewall Software
Modify

Opened 16 years ago

Closed 9 years ago

#2991 closed enhancement (duplicate)

WebAdmin: default milestone cannot be assigned

Reported by: Emmanuel Blot Owned by: Jonas Borgström
Priority: low Milestone:
Component: roadmap Version: devel
Severity: minor Keywords: admin web_ui
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

WebAdmin does not manage milestones, as milestones can be managed from the TracRoadmap interface.

However, this interface does not allow to assign a default milestone to new tickets.

This default milestone setting could be added to the TracRoadmap interface. However it seems it would be better to implement it in the WebAdmin plugin, as this is the only component that may change the trac.ini file.

Btw, these kinds of settings might also be stored in the DB rather than in the trac.ini file.

Attachments (0)

Change History (5)

comment:1 by Matthew Good, 16 years ago

Resolution: duplicate
Status: newclosed

Well, if you could've waited a few hours a patch was added in #2992 :)

comment:2 by simon@…, 12 years ago

Resolution: duplicate
Status: closedreopened

Since you can create and edit milestone from the TracRoadmap interface if you have MILESTONE_CREATE/MILESTONE_EDIT it makes sense that you should be able to set a milestone to default if you have one of those permissions, from the same place. To go through the WebAdmin interface you need (?) TRAC_ADMIN.

(Also, it is confusing that editing milestones from TracRoadmap and WebAdmin gives slightly different interfaces, e.g. you cannot retarget tickets when you complete a milestone from WebAdmin. But that is perhaps for a different ticket.)

in reply to:  2 ; comment:3 by Christian Boos, 12 years ago

Component: generalroadmap
Keywords: admin web_ui added
Milestone: next-major-0.1X

Replying to simon@…:

(Also, it is confusing that editing milestones from TracRoadmap and WebAdmin gives slightly different interfaces,

The admin interface is more interesting for having an overview of all the milestones, and do changes meaningful for a group of milestones, like setting the default, or deleting several milestones at once.

For this reason, I think that MILESTONE_ADMIN should be needed for being able to set the default (to be verified).

Now for the modifying an individual milestone, we should probably find a way to integrate better the current "normal" milestone edit with the admin interface.

Last edited 9 years ago by Ryan J Ollos (previous) (diff)

in reply to:  2 comment:4 by Ryan J Ollos, 9 years ago

Replying to simon@…:

Since you can create and edit milestone from the TracRoadmap interface if you have MILESTONE_CREATE/MILESTONE_EDIT it makes sense that you should be able to set a milestone to default if you have one of those permissions, from the same place. To go through the WebAdmin interface you need (?) TRAC_ADMIN.

It has been a long time since this comment was made, but the current behavior now is that a user must have TICKET_ADMIN and MILESTONE_VIEW to access the Milestone admin page. I've opened #11341 to consider allowing users with MILESTONE_ADMIN but not TICKET_ADMIN to access this page.

(Also, it is confusing that editing milestones from TracRoadmap and WebAdmin gives slightly different interfaces, e.g. you cannot retarget tickets when you complete a milestone from WebAdmin. But that is perhaps for a different ticket.)

The latter will be dealt with in #3754, most likely for Trac 1.1.3.

in reply to:  3 comment:5 by Ryan J Ollos, 9 years ago

Milestone: next-major-releases
Resolution: duplicate
Status: reopenedclosed

Replying to cboos:

For this reason, I think that MILESTONE_ADMIN should be needed for being able to set the default (to be verified).

I described in #11341 why TICKET_ADMIN should be required to set default_milestone, but I also think a user with MILESTONE_ADMIN should be allowed to access the Admin Milestone page. Please let me know what you think of the suggestions.

Now for the modifying an individual milestone, we should probably find a way to integrate better the current "normal" milestone edit with the admin interface.

In comment:4 I mentioned #3754, but specifically, see comment:5:ticket:3754.

I think those two tickets cover all of the requests and suggestions in this ticket, so I'll close it again since the request in comment:description is a duplicate of #2992.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.