Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2734 closed defect (duplicate)

can't view changesets which go outside repository_dir

Reported by: zovirl1@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/changeset view Version: 0.9.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When I try to view a certain changeset, I get this:

Error: No node at app/views/todo/list.rhtml in revision 141

Here is what I did:

  1. I copied an existing svn directory for experimenting with trac:
    svn copy http://localhost/svn/todo http://localhost/svn/todo_list
    
  2. I set Trac's repository_dir to /space/svn/todo_list
  3. I changed list.rhtml and tried to view the changeset. I got the error message above.

Other changesets which are wholly contained within repository_dir seem to work. The ones that go outside repository_dir (thanks to my svn copy command) don't work. If I change repository_dir to /space/svn/ and resync, then I can view all the changesets. This seems a lot like #1930, but that was fixed (in theory).

Attachments (0)

Change History (1)

comment:1 by anonymous, 14 years ago

Resolution: duplicate
Status: newclosed

duplicate of #1830.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.