Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#1930 closed defect (fixed)

Revision log is broken when trying to view the root of a virtual repository

Reported by: sean.dawson@… Owned by: Christian Boos
Priority: highest Milestone: 0.9
Component: version control/log view Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I've set my trac.ini as follows:

repository_dir = /some/path/to/repo/project1

where /some/path/to/repo is the physical path of my repository, and project1 is a versioned directory inside the repository. Clicking "Browse Source" correctly displays project1 as the new root, but clicking "Revision Log" results in an error:

The file or directory '/' doesn't exist at revision xxx or at any previous revision.

Note: the revision log works properly for any path under root; only for root does it give the error. I tried to dig around and determine if the scope wasn't being added properly, but I didn't look very hard :)

Attachments (1)

scoped_get_path_history.patch (15.6 KB ) - added by Christian Boos 14 years ago.
get_path_history now takes into account the repository scope

Download all attachments as: .zip

Change History (7)

comment:1 by Christopher Lenz, 14 years ago

Milestone: 0.9
Resolution: duplicate
Status: newclosed

I think this is a duplicate of #1830. I've not yet seen any problems with subsets of a repository that are fully self-contained, but have seen exactly the problem you're reporting with those that aren't.

Maybe the root directory in this case was copied from a path outside the scope?

Anyway, can you test the patch attached to #1830 and see if that fixes the problem for you?

comment:2 by Christopher Lenz, 14 years ago

Milestone: 0.9
Resolution: duplicate
Status: closedreopened

Just noticed that I'm seeing this problem at my own site, and it's not because the selected repository subset is not self-contained.

comment:3 by Manuzhai, 14 years ago

#2046 is a duplicate of this one. It has the relevant traceback from the Trac log.

by Christian Boos, 14 years ago

get_path_history now takes into account the repository scope

comment:4 by Christian Boos, 14 years ago

Owner: changed from Jonas Borgström to Christian Boos
Priority: normalhighest
Status: reopenednew

I've attached a fix, which also contains a big bunch of unit-tests for the scoped repository situation.

comment:5 by Christopher Lenz, 14 years ago

cboos, that patch looks good and works for me. Nice work! Feel free to check this in.

comment:6 by Christian Boos, 14 years ago

Resolution: fixed
Status: newclosed

Thanks! Patch applied in r2311.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.