Edgewall Software
Modify

Opened 14 years ago

Closed 13 years ago

#2622 closed enhancement (duplicate)

Show ticket status in notification email

Reported by: tomek.piatek@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.3
Severity: normal Keywords: ticket notification mail
Cc: Branch:
Release Notes:
API Changes:

Description


Attachments (0)

Change History (9)

comment:1 by Emmanuel Blot, 14 years ago

Can you be more descriptive ?

The status of a ticket is already part of the message body of a notification email (in the ticket header). What would you want to be added/changed ?

comment:2 by anonymous, 14 years ago

Err, sorry about that. I mean to say "show status in email subject". This is helpful as at a glance I would be able to see how many "new" tickets I have in my trac folder.

comment:3 by anonymous, 14 years ago

Newly created tickets would not have a RE: in the subject line so in that respect, the status is in the subject.

comment:4 by Emmanuel Blot, 14 years ago

At the very least, this feature should be enabled by an option:
The same ticket would appear with different subjects [dep. on its status], which can lead to confusion for sorting ticket emails.

Another option could be to add another SMTP header, such as X-Trac-Ticket-Status, to specify the status of the ticket: any good MUA (email client) could sort the emails using this header.

comment:5 by Emmanuel Blot, 14 years ago

#2728 has been marked as a duplicate of this ticket.

comment:6 by sid, 13 years ago

#1359 is a ticket (with a patch) about adding the SMTP header information.

comment:7 by sid, 13 years ago

#3136 added ability to make the project prefix configurable. This should probably build off that work.

comment:8 by Rajiv, 13 years ago

It would be nice if the subject of the email read more like the title of the RSS feed. Examples:

Ticket #16 (defect closed): Cannot post Comment Ticket #11 (enhancement created): Command line interface

Can't we have a ticket_notify_email_subject.cs? I could then edit it to pickup the change title etc.

comment:9 by Christian Boos, 13 years ago

Resolution: duplicate
Status: newclosed

See #1480.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.