Edgewall Software
Modify

Opened 16 years ago

Closed 13 years ago

Last modified 19 months ago

#11 closed enhancement (fixed)

Web configuration/administration in addtion to trac-admin

Reported by: Jonas Borgström Owned by: Christopher Lenz
Priority: highest Milestone: 0.11
Component: general Version: devel
Severity: normal Keywords: config admin
Cc: tiger@…, trapni@…, dimitrisp.lists@…, john@…, patrys@…, nunterberg@…, shacka@…, edgewall.com@…, bd@…, whylee@…, ruben.lozano.a@…, danny@…, andy_l@…, panagiotis.korros@…, mmass@…, trac.tickets@… Branch:
Release Notes:
API Changes:

Description

The module should allow (trusted) users to configure things like:

  • User permissions
  • Available ticket components, milestones, versions…
  • Settings like theme, htdocs-location, cgi-name…

Attachments (2)

tracperms.jpg (53.3 KB ) - added by StefanW@… 14 years ago.
Editing Permissions for different projects and different users looks like this. svn-permissions is not finished yet and doesnt look that good
svnperms.jpg (40.9 KB ) - added by whylee@… 14 years ago.
Example of a permission GUI for SVN (developed in php)

Download all attachments as: .zip

Change History (50)

comment:1 by Jonas Borgström, 16 years ago

I just want to point out that you can use the text based svn:trunk/scripts/trac_admin.py script until is web interface is added.

comment:2 by daniel, 16 years ago

Priority: highnormal
Summary: Configuration module is missing(Web) configuration module is missing
Version: 2.0

trac_admin.py is now called svn:trunk/scripts/trac-admin.

comment:3 by Jonas Borgström, 16 years ago

Milestone: 2.0
Version: 2.00.1

comment:4 by daniel, 16 years ago

Version: 0.1Trunk

comment:5 by daniel, 16 years ago

Version: Trunkdevel

comment:6 by daniel, 16 years ago

Severity: normalenhancement

comment:7 by daniel, 16 years ago

Milestone: 2.00.9
Priority: normalhighest
Summary: (Web) configuration module is missingWeb configuration/administration instead of trac-admin

At some point we should obsolete trac-admin with a 'pure' web-based interface. Tentatively for 0.9.

comment:8 by rocky, 16 years ago

I would recommend against obsoleting trac-admin. trac-admin is extremely useful for automating configurations. Plus, its a great way to initialize an 'admin' user with all access before even having to launch a web process. My recommendation would be to simply have both trac-admin and the web interface reuse the same core python code for doing stuff.

comment:9 by daniel, 16 years ago

I agree with that.

comment:10 by StefanW@…, 15 years ago

trac-admin is also useful for other (web)Gui-Programs to add new projects or edit project-permissions like it is on our small PHP-Web-Interface for adding new users, projects etc. Pleople, who use (old? versions of) trac can use this for multiple projects. If interested, download it from my server: http://www.whylee.at/opensource/projectportal.zip (Sometimes my server does not have a good connection. try again i a minute)

I released it under GPL. If you can use it, fine. If you modify it and you think everone could use your modification, please send your modifications to me. ( whylee@… )

Geetings,

Weilhartner Stefan, 4ahead

comment:11 by remi2402@…, 15 years ago

What about having a mix of both?

  • Keep trac-admin for all administrative tasks as it stands today
  • web interfaces for everything except low-level stuff (svn repos, trac env path, …)

This way, TRAC_ADMIN users could manage almost all of trac without actually needing shell access. I, for one, wouldn't mind having this kind of possibilities.

Rémi (faithfull trac user)

comment:12 by daniel, 15 years ago

Keywords: config admin added
Milestone: 0.92.0

This is an important feature for 2.0

comment:13 by Brad Anderson <brad@…>, 15 years ago

I've put together a bit of code for this.

See: http://68.91.106.142/projects/test/

and let me know if I'm on the right track.

comment:14 by Christopher Lenz, 15 years ago

I don't think we should push this to milestone:2.0, it's just too important a feature and should really make it into milestone:1.0. And now we have Brad working on a patch, too. :-)

My vote would be to put this on the plate for milestone:0.9.

comment:15 by agizis, 15 years ago

Brad's demo seems like a huge step forward!

It's fine if things like themes stay done through files and command lines, but adding a milestone or component should be done through the web just like creating a ticket, because the project manager is probably just another web user, and not the system administrator.

Please, please, please, try to get this into 0.9!

comment:16 by aadis-trac@…, 15 years ago

I also vote for 0.9, or at least 1.0.

Very useful feature

comment:17 by jbolla, 15 years ago

Summary: Web configuration/administration instead of trac-adminWeb configuration/administration in addtion to trac-admin

At the very least, would like web interfaces to manage component, version, priority, and severity.

comment:18 by anonymous, 15 years ago

Milestone: 2.00.9

comment:19 by brad <brad@…>, 15 years ago

The link I gave on Nov 8 has an IP address. It's still valid, but the vhost is not anymore. Use this:

http://trac.dsource.org/projects/test/admin/ticket

comment:20 by sreimers, 15 years ago

Any chance we will get WebAdmin capability in 0.9 timeframe? I just got the patch from brad working against latest trunk (rearch changes and all) - anyone interested in a patch?

comment:21 by anonymous, 15 years ago

Cc: tiger@… added

comment:22 by anonymous, 15 years ago

Yes it would be nice to post a patch here.

comment:23 by Christian Parpart <trapni@…>, 14 years ago

Cc: trapni@… added

I highly vote to be included with trac 0.9 :)

comment:24 by sreimers <sven.reimers@…>, 14 years ago

Ok. Try to get it working with new pluggable architecture, and post it here afterwards. No patching necessary anymore, just some additional files if I understand new arch.

comment:25 by Christopher Lenz, 14 years ago

Milestone: 0.91.0

Okay, this isn't going to happen for 0.9, but it's highest priority for 1.0. Sorry.

comment:26 by jeoffwilks@…, 14 years ago

I modified Brad's patch to work with the Debian Sarge 'trac' package (0.8.1-2, ~ r1310). I attached the patch to his Trac wiki at: http://trac.dsource.org/projects/test/wiki/TracWebAdminDevelopment

comment:27 by dimitrisp <dimitrisp.lists@…>, 14 years ago

Cc: dimitrisp.lists@… added

comment:28 by Matthew Good, 14 years ago

#1012 has been marked as a duplicate of this ticket.

comment:29 by anonymous, 14 years ago

Cc: john@… added

Eagerly awaiting this as well. :-)

comment:30 by patrys@…, 14 years ago

Cc: patrys@… added

Please leave me in the CC field, I am currently maintaining the PLD Linux spec file for Trac.

comment:31 by Norbert Unterberg <nepo@…>, 14 years ago

Cc: nunterberg@… added

comment:32 by anonymous, 14 years ago

Cc: shacka@… added

comment:33 by Ryan Herbert <edgewall.com@…>, 14 years ago

Cc: edgewall.com@… added

comment:34 by anonymous, 14 years ago

Brad (& Jeoff) have done some good work here. I strongly feel that it would be better to have a partial webadmin implementation in 0.9 final than no web administration at all..

Agreed that trac-admin needs to always exist (makes automated installs a breeze), but that being the only practical way to administer basic things like components / versions etc does not impress PHBs who need to sign off on production Trac deployment.

comment:35 by Matthew Good, 14 years ago

Web administration is currently available for 0.9 as an external plugin: source:/branches/jonas-dev/webadmin

This will be packaged separately for now, and most likely bundled with 1.0.

comment:36 by anonymous, 14 years ago

Cc: bd@… added

by StefanW@…, 14 years ago

Attachment: tracperms.jpg added

Editing Permissions for different projects and different users looks like this. svn-permissions is not finished yet and doesnt look that good

comment:37 by anonymous, 14 years ago

Cc: whylee@… added

User-interface-example how permissions could be handled: As you can see in the attached image tracperms.jpg, the user-interface is not 'compatible' to the trac-user-interface. We buildt our own development-portal in php where we can add new projects and users and adjust permissions for trac and svn. I think that if the developers from trac decide to add that permission-feature it would be cool if you make this suitable for a multi-project-configuration. Also svn-permissions would be fine. Thanks, WhyLee.

(Our source is in php which uses the trac-admin command-line tool for modifying the permissions, 'direct'-intergration in python in trac would be a more elegant solution)

comment:38 by anonymous, 14 years ago

Cc: ruben.lozano.a@… added

comment:39 by dadair, 14 years ago

Cc: danny@… added

comment:40 by anonymous, 14 years ago

Cc: andy_l@… added

by whylee@…, 14 years ago

Attachment: svnperms.jpg added

Example of a permission GUI for SVN (developed in php)

comment:41 by anonymous, 14 years ago

Cc: panagiotis.korros@… added

comment:42 by anonymous, 14 years ago

Cc: mmass@… added

comment:43 by Christopher Lenz, 14 years ago

Milestone: 1.00.11

comment:44 by Gunnar Wagenknecht <gunnar@…>, 14 years ago

Cc: gunnar@… added

comment:45 by anonymous, 13 years ago

Cc: trac.tickets@… added

comment:46 by anonymous, 13 years ago

Cc: gunnar@… removed

comment:47 by Christopher Lenz, 13 years ago

Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

I'm working on integrating WebAdmin into the core for the next release.

comment:48 by Christopher Lenz, 13 years ago

Resolution: fixed
Status: assignedclosed

Done in [4095].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.