Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2605 closed enhancement (duplicate)

Timeline should be more verbose

Reported by: boris.leidner@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: timeline Version: 0.9.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

The timeline of trac could be a bit more verbose. I would like to have additional entries to be displayed:

  • Comments on tickets (even if resolution is not changed)
  • User accepted his ticket
  • Ticket summary should be displayed for every ticket entry in the timeline, so you know what ticket XXX is about without clicking on the ticket

Others:

  • Links on wiki changeset entries lead to the wiki entry rather to the wiki changeset

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 14 years ago

The first two requests are already there (see TracIni#timeline)

The third one begins to be requested more and more often… We should start to consider it.

As for the last one, sorry I don't really understand what you mean here.

comment:2 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

For the third point, see #2454.

For the fourth, I guess this is a duplicate of #239.

comment:3 by anonymous, 14 years ago

I am actually having version 0.9.3 installed. And I do not see that any added comment to a ticket results in the timeline entry like

Ticket #xx (Task) was CHANGED by XXX
or Ticket #xx (Task) got a comment from XXX

Only new and closed actions are displayed.

I did in fact set the option

ticket_show_details = true

in the trac.ini file.

Is this feature really already there? Starting from which Revision?

comment:4 by anonymous, 14 years ago

Resolution: duplicate
Status: closedreopened

reopening just to get an answer…

comment:5 by anonymous, 14 years ago

Resolution: duplicate
Status: reopenedclosed

You have to turn on the Ticket Details option on the timeline page. This is off by default, but the setting is saved between sessions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.