Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

Last modified 8 years ago

#2454 closed enhancement (fixed)

All ticket entries on the Timeline should show the Summary

Reported by: mcarpenter@… Owned by: Christian Boos
Priority: normal Milestone: 0.11
Component: timeline Version: 0.9.1
Severity: minor Keywords: tickettype, traclinks
Cc: m@…, mcarpenter@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Seeing entries on the timeline like this

Ticket #3485 (defect) updated by mcarpenter

isn't really meaningful, even if you can get the summary by mousing over the ticket number. Mousing over every entry is a chore. I don't see why the issue type is more important than the title.

An entry like

Ticket #3485 ("No printer is installed": find the cause) updated by mcarpenter

would be much more useful, even if the Summary does sometimes take up a lot of room. The #999 (Summary) formatting matches the <title> of the ticket's page.

Attachments (1)

patch-for-2454.trac-0.9.1.patch (1.2 KB ) - added by anonymous 16 years ago.
Patch to switch summary and ticket type

Download all attachments as: .zip

Change History (12)

comment:1 by anonymous, 16 years ago

Also this would make a print out of the timeline more useful.

comment:2 by anonymous, 16 years ago

Type: defectenhancement

comment:3 by anonymous, 16 years ago

Hovering over the ticket link will give you the summary in a popup so I don't see any reason for it to directly on the page. Of course adding it only for printouts may possibly be useful, but I don't see printing of a timeline being done very often.

comment:4 by mcarpenter@…, 16 years ago

Version: 0.9.20.9.1

anonymous wrote:

Hovering over the ticket link will give you the summary in a popup so I don't see any reason for it to directly on the page.

I wrote:

Mousing over every entry is a chore.

To expand on that, on my timeline for my project today I have 30-40 entries for tickets on the timeline. Knowing what the issue about is important to figure out what needs follow up on. Should I be mousing over all 30 ticket links? That seems to be a pain to me.

Attaching patch for this change.

by anonymous, 16 years ago

Patch to switch summary and ticket type

comment:5 by Christian Boos, 16 years ago

Milestone: 0.10
Owner: changed from Jonas Borgström to Christian Boos

I think the ticket type should come before the ticket summary. What about:

Ticket #2598 (defect: SQL logic error or missing database when database seems fine) created by dangoor+trac@gmail.com

See also #2070.

comment:6 by Markus Tacker <m@…>, 16 years ago

Cc: m@… added

comment:7 by Christian Boos, 16 years ago

Milestone: 0.101.0
Severity: normalminor

No consensus on that yet. Post-poning.

comment:8 by Christian Boos, 15 years ago

Keywords: traclinks tickettype added
Milestone: 1.00.11
Resolution: fixed
Status: newclosed

Implemented in r4773, the way originally requested.

The link title now contains the type as well as the status/resolution informations.

comment:9 by Ryan J Ollos, 8 years ago

Keywords: traclinks tickettype → traclinks, tickettype

comment:10 by Ryan J Ollos, 8 years ago

Keywords: traclink added; traclinks removed

comment:11 by Ryan J Ollos, 8 years ago

Keywords: traclinks added; traclink removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.