Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 7 years ago

#2527 closed defect (duplicate)

Full side by side diffs

Reported by: rkuo@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: version control Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

We use Trac for examining changesets for code reviews. It works well, but one of the major failings is that there is no ability to look at a full side by side diff of the old vs new file. Seeing the entire code is often necessary to put the changes into context.

I would like to request that a "(full diff)" link be placed along side modified files in the changeset view which links to a page that displays a full side by side diff view. I think this would be a relatively simple addition that would add a lot of value to code reviews.

Attachments (0)

Change History (2)

comment:1 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #927 which has been implemented so that you can enter "all" in the numer of lines to display.

comment:2 by Christian Boos, 7 years ago

Milestone: 0.9.3

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.