Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2526 closed enhancement (fixed)

Changeset view should not Wiki-Format the commit message

Reported by: aaron@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.10
Component: version control/changeset view Version: devel
Severity: normal Keywords: changeset, message
Cc: Branch:
Release Notes:
API Changes:

Description

In my opinion the changeset view should not wiki-format the commit messages; in general, a subversion log message is not wiki-formatted but just plain text.

Especially with Java Code (where one often uses CamelCase) the wiki-style formatting can be a pain. It would be great if one could turn it off and set it to plain text instead.

Attachments (0)

Change History (7)

comment:1 by aaron@…, 14 years ago

Type: defectenhancement

comment:2 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #476.

comment:3 by Jon <jon@…>, 14 years ago

Keywords: changeset message added
Resolution: duplicate
Severity: minornormal
Status: closedreopened
Summary: The changeset view should not Wiki-Format the commit messageChangeset view should not Wiki-Format the commit message
Version: 0.9.2devel

I'm reopening this ticket because it's issue is broader than #476 (which I also commented on). Like I said there the WebKit trac system is misrendering the SVN logs because the message field of the Changeset view is being rendered using wiki code. An option to turn off wiki code for this field or treating its contents as though implicitly enclosed in a preformatted code block would be satisfactory solutions.

comment:4 by Christopher Lenz, 14 years ago

Milestone: 0.10
Owner: changed from Jonas Borgström to Christopher Lenz
Status: reopenednew

comment:5 by Christopher Lenz, 14 years ago

Status: newassigned

Working on this.

comment:6 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Added an option for this in [3246]:

{changeset]
wiki_format_messages = no

(defaults to true, of course)

comment:7 by Russell Hind <rhind@…>, 14 years ago

Just to say I'm glad you left an option in for this. We don't use full wiki formatting in our commit messages (such as ! to stop wiki links etc) but we do use rXXXX for revisions and * for bullet lists because these look fine as both plain text and wiki formatted.

Thanks

Russell

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.