Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2525 closed defect (duplicate)

Windows Initenv Error

Reported by: kismet,sl@… Owned by: daniel
Priority: normal Milestone:
Component: admin/console Version: 0.9.2
Severity: normal Keywords: window initenv
Cc: Branch:
Release Notes:
API Changes:

Description

I'm trying to install trac on the following sysetm:

  • OS: Win XP Pro SP2
  • SVN: 1.2.3
  • Python: 2.3
  • trac: 0.92

But I get the following error when I excute trac-admin <path> initenv. Here are the last output line that I get:

 C:\Server\Python23\share\trac\wiki-default\WikiProcessors => WikiProcessors
 C:\Server\Python23\share\trac\wiki-default\WikiRestructuredText => WikiRestruct
uredText
 C:\Server\Python23\share\trac\wiki-default\WikiRestructuredTextLinks => WikiRes
tructuredTextLinks
 C:\Server\Python23\share\trac\wiki-default\WikiStart => WikiStart
 Indexing repository
Failed to initialize environment. null argument to internal routine
Traceback (most recent call last):
  File "C:\Server\Python23\Lib\site-packages\trac\scripts\admin.py", line 617, i
n do_initenv
    repos.sync()
  File "C:\Server\Python23\Lib\site-packages\trac\versioncontrol\cache.py", line
 83, in sync
    for path,kind,action,base_path,base_rev in changeset.get_changes():
  File "C:\Server\Python23\Lib\site-packages\trac\versioncontrol\svn_fs.py", lin
e 488, in get_changes
    change.base_path, pool())
SystemError: null argument to internal routine

Attachments (0)

Change History (2)

comment:1 by kismet.sl@…, 14 years ago

Sorry I've wrote a mispelled e-mail address, the correct on is is kismet.sl@…

comment:2 by Christopher Lenz, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #2440.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.