Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2524 closed defect (duplicate)

can't use "./setup.py --home=..." to install trac locally

Reported by: Artem Baguinski <femistofel@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I'd like to install trac in my home directory on a webserver I don't own. If I try to

  python setup.py install --home=~/local/stow/trac

I get:

running install
Traceback (most recent call last):
  File "setup.py", line 237, in ?
    cmdclass = {'install': my_install,
  File "/usr/lib/python2.3/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib/python2.3/distutils/dist.py", line 907, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.3/distutils/dist.py", line 927, in run_command
    cmd_obj.run()
  File "setup.py", line 31, in run
    self.siteconfig()
  File "setup.py", line 34, in siteconfig
    conf_dir = os.path.join(self.prefix, 'share', 'trac', 'conf')
  File "/usr/lib/python2.3/posixpath.py", line 62, in join
    elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'

Because self.prefix doesn't exist. I can workaround using --prefix.

Attachments (0)

Change History (1)

comment:1 by Christopher Lenz, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #963.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.