Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2317 closed defect (invalid)

"Add milestone" link has vanished

Reported by: webkontakt@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: roadmap Version: 0.9
Severity: minor Keywords:
Cc: webkontakt@… Branch:
Release Notes:
API Changes:

Description

Since the upgrade from 0.8.4 to 0.9 there is no "Add milestone" link anymore in the roadmap section. I still can edit and delete milestones per button, but adding is only possible via trac-admin. I have TRAC_ADMIN permissions

Attachments (0)

Change History (6)

comment:1 by Christopher Lenz, 14 years ago

Milestone: 0.9.1
Resolution: invalid
Status: newclosed

Look at the bottom of the roadmap page.

(And also see #2095)

comment:2 by webkontakt@…, 14 years ago

Resolution: invalid
Status: closedreopened

Sorry to reopen this, but I searched all the page (and even the source code) before filing this ticket: there is no button at all on the roadmap page. And I really have TRAC_ADMIN permissions.

I experienced this behavior in 4 different trac environments that I upgraded to 0.9. The "Add" button, however, appears in newly created trac 0.9 environments. It seems something went wrong during the upgrade process.

comment:3 by anonymous, 14 years ago

It sounds like a browser caching problem. Be sure to make the browser do a full reload of the roadmap page.

comment:4 by anonymous, 14 years ago

Milestone: 0.9.1

It's definitely not a caching issue. The problem is persistent, occuring for several days on different computers. I surely tested this before.

comment:5 by webkontakt@…, 14 years ago

I found the reason for this behavior (which is reproducable for any upgraded trac environment):

Whenever I open a new browser instance and go to the Roadmap, I am always marked as "logged off" - that's why there never is an "Add" button. I am logged in for any other page, but for the Roadmap page I am not logged in until I explicitely do - then this remains persistent until I close the browser. Nevertheless, this behavior is strange and a source of confusion.

Perhaps someone else can change the summary to something appropriate and/or close this.

comment:6 by Christopher Lenz, 14 years ago

Milestone: 0.9.1
Resolution: invalid
Status: reopenedclosed

This is a problem with your web server configuration. Please follow-up on this on the MailingList or IrcChannel if you don't find a way to fix it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.