Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2316 closed defect (duplicate)

Timeouts and broken images/CSS in Trac rendering

Reported by: spike@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Since upgrading to .9b2, I've noticed a lot of failures loading images and stylesheets in the Trac interface. These failure seems to be timeout related, because when they occur, it takes a long time to load the request Trac page (upwards of 30 seconds).

In .8, it was my understanding that Trac used non-CGI mapped URL to serve up its static assets, but in .9, it appear that the asset URLs now get served back through the CGI URL.

My guess is that Trac is now serving up its static files directly through the CGI handler and may be doing something incorrectly (like maybe not closing the HTTP output stream or setting the content-length handler?) which is causing the browser to think the file contents are not finished being served, so keeps waiting for more content to arrive before it finally times out.

I have reproduced these results in both IE and Firefox.

Attachments (0)

Change History (2)

comment:1 by anonymous, 14 years ago

For anyone else who encounters this issue, I managed to workaround this issue by adding an alias that lets Apache directly serve up the Trac files rather than routing them through the CGI handler:

AliasMatch ^/cgi-bin/trac.cgi/chrome/common(.*) /usr/share/trac/htdocs$1

comment:2 by Matthew Good, 14 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #2038.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.