Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#2239 closed defect (fixed)

Cannot view history of files which have been moved

Reported by: Dave Matthews Owned by: Christian Boos
Priority: normal Milestone: 0.9
Component: version control/browser Version: 0.9b2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

source:trunk/wiki-macros/HelloWorld.py demonstrates the problem. You can view the full history of the latest version by enabling the follow copies option. From there you can view rev 1519. However, if you then try to view the revision history of that version it only shows adds, moves and deletes so you only see rev 167 and rev 1636. If you try to enable follow copies this get ignored (even though it is selected in the URL). You can view the change history of the file if you manually enter rev 1519 but there is no way to get to this from the web interface.

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 14 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christian Boos
Status: newassigned

The problem is that the Revision Log link doesn't specify the start revision, so the latest revision is used. Since there's no such path at the latest revision, the Revision Log view fallbacks to the shows adds, moves and deletes mode.

Note that this is not true with the current trunk anymore: now, you'll get an explicit error message, see #2110).

The fix would be that the Revision Log link should also specify the revision at which to start:

  • browser.py

     
    101101                           if not name in hidden_properties]),
    102102            'href': util.escape(self.env.href.browser(path, rev=rev or
    103103                                                      repos.youngest_rev)),
    104             'log_href': util.escape(self.env.href.log(path))
     104            'log_href': util.escape(self.env.href.log(path, rev=rev))
    105105        }
    106106
    107107        path_links = get_path_links(self.env.href, path, rev)

comment:2 by Christian Boos, 14 years ago

Resolution: fixed
Status: assignedclosed

Fixed in r2382.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.