Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2192 closed defect (fixed)

"big" fields useless and mess with formatting in email notification

Reported by: m.kooijman@… Owned by: Christopher Lenz
Priority: low Milestone: 0.9
Component: ticket system Version: 0.9b1
Severity: normal Keywords:
Cc: m.kooijman@… Branch:
Release Notes:
API Changes:

Description

There is a small error with formatting of email notifications. "big" fields were counted for determining even/odd (left column/right column) of a field, even though they were not displayed. in Notify.py, i is used for determining if "left" or "right" formatting should be used and if there should be an extra newline in the end. If any "big" fields are present, these big fields are counted in i, but they are not actually displayed, which messes up the formatting.

To fix this, one could decrement i after deciding a field is "big". Or, nicer, one could manually increment i after displaying a normal field, instead of letting the for loop do that.

Also, it seems this issue can only be reproduced by having newlines in a non-textarea custom field, which I could only produce by changing the type of a textarea to text after putting in a value with newlines. This is because textarea fields are filtered out a little earlier, so textarea fields don't even stand a chance of becoming big fields.

I think initializing big with a list of all textarea fields would also make sure that they are properly displayed in notify emails (they aren't at all right now).

I would have made patch, if I would know list handling in python a little better, and it wasn't 4 am already ;-)

Tested with 0.9b1, but there are no relevant changes in b2 or trunk which affect this.

Attachments (0)

Change History (4)

comment:1 by anonymous, 14 years ago

Cc: m.kooijman@… added

comment:2 by Christopher Lenz, 14 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christopher Lenz
Priority: normallow
Status: newassigned

comment:3 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed in [2331], [2332], [2333].

comment:4 by anonymous, 14 years ago

Commenting…………….

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.