Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2193 closed enhancement (duplicate)

Sub-ticket support

Reported by: SimonLei Owned by: Christian Boos
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: normal Keywords: xref relation
Cc: Branch:
Release Notes:
API Changes:

Description

When a new ticket created, the user can assign the new ticket a parent ticket. It's very useful in project management. For example, when I have a feature to be implemented, I submit a ticket in the trac. Then, I found there are 3 tasks to implement the feature, and each task can be broken down into 6 subtask. It's very clear to know how much subtask is complement, and how long should we finish the feature.

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 14 years ago

Keywords: xref relation added
Owner: changed from Jonas Borgström to Christian Boos

That would be the parent/child relationship described in #886.

Let's keep this ticket open to discuss UI/implementation details of this particular feature.

Instead of assigning an arbitrary parent to a New Ticket, I think it would be more convenient to have a Create Sub-ticket button in a Relations section. That section would be located below the ticket description, and above the Attachments section.

Clicking on the Create Sub-ticket button would create a new ticket:

  • with a <<child-of>> relationship to its parent
  • with most of the fields pre-filled according to the values of the parent; they won't necesseraly be kept, but it would be a good start

comment:2 by Christopher Lenz, 14 years ago

Resolution: duplicate
Status: newclosed

cboos, I don't see the need to fragment the discussion on tickets. This is a duplicate of #886, so let's close this and take any discussion there.

We have way to many open tickets already, and spreading similar/same requests across multiple tickets can't be a good idea.

comment:3 by Christian Boos, 14 years ago

I don't see the need to fragment the discussion on tickets.

…maybe for having a sub-ticket of a bigger ticket in order to keep the discussion focused on a particular detail of the parent ticket?

From this perspective:

  • #31 is the main ticket (ticket dependencies in general),
  • #886 is a sub-ticket of #31 (focusing on parent/child relationships)
  • this one is a sub-ticket of #886, discussing the UI for creating a sub-ticket (maybe I should have changed the summary)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.