Edgewall Software
Modify

Opened 17 years ago

Closed 7 years ago

Last modified 7 years ago

#2082 closed defect (fixed)

Description lists are unescapable

Reported by: Christian Boos Owned by: Christian Boos
Priority: normal Milestone: 0.10
Component: wiki system Version: 0.9b1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Once a "::" is seen in an indented line, it's always recognized as a description list separator, and there's no way to escape it.

In a bulleted list, it's OK, therefore I can write the following:

  • neither with "!::" (rendered as "!::")
  • nor with the code block syntax {{{::}}} (rendered as ::)
  • nor with backticks `::` (rendered as ::).

But if I repeat the above 3 lines, this time without the bullet:

neither with "!::" (rendered as "!::") nor with the code block syntax {{{::}}} (rendered as ::) nor with backticks `::` (rendered as ::).

The :: turns each line in a description term, ignoring any form of escape.

Attachments (0)

Change History (9)

comment:1 by Matthew Good, 17 years ago

Owner: changed from Jonas Borgström to Matthew Good
Status: newassigned

Ok, I guess since I wrote the DL stuff I'll take this one.

comment:2 by Christian Boos, 17 years ago

Description: modified (diff)
Milestone: 0.9.4

comment:3 by Christopher Lenz, 17 years ago

#2704 has been marked as duplicate of this ticket.

comment:4 by Christopher Lenz, 17 years ago

Milestone: 0.9.40.10

Not going to happen for 0.9.4.

comment:5 by Christian Boos, 16 years ago

Owner: changed from Matthew Good to Christian Boos
Status: assignednew

Stealing the ticket…

comment:6 by Christian Boos, 16 years ago

Resolution: fixed
Status: newclosed

Fixed in r3004.

comment:7 by valentin.guerlesquin.prestataire@…, 10 years ago

Resolution: fixed
Status: closedreopened

Hi there,

Seems to still exists on up-to-date versions of Trac. Tested on online demo of 0.12. According to my understanding, following code should display items (desc1, desc2, desc3) in monospace font + no wiki processing of the two :. This is not what happen.

Example below

 {{{desc1::}}}:: blahblabla
 {{{desc2::}}}:: blahblabla
 {{{desc3::}}}:: blahblabla

renders as:

{{{desc1
blahblabla
{{{desc2
blahblabla
{{{desc3
blahblabla
Last edited 10 years ago by Christian Boos (previous) (diff)

comment:8 by Ryan J Ollos, 7 years ago

Resolution: fixed
Status: reopenedclosed

Re-closing ticket assigned to milestone:0.10. Please create a new ticket for the issue.

in reply to:  8 comment:9 by Ryan J Ollos, 7 years ago

Replying to Ryan J Ollos:

Re-closing ticket assigned to milestone:0.10. Please create a new ticket for the issue.

#12214

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.