Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#1893 closed defect (fixed)

[patch] Move email notification support checking from Notify to NotifyEmail

Reported by: Bruce Christensen <trac@…> Owned by: Jonas Borgström
Priority: normal Milestone: 0.9
Component: general Version: devel
Severity: normal Keywords:
Cc: vyt@… Branch:
Release Notes:
API Changes:

Description

Notify.Notify.notify() currently checks for Python ≥ 2.2.2. However, this is necessary only for email notifications, so the code should be moved to Notify.NotifyEmail.notify(). This allows other types of notification (IM, pager, etc.) to work properly with a lower version of Python.

Attachments (2)

emailnotify-r2055.patch (1.1 KB ) - added by Bruce Christensen <trac@…> 14 years ago.
Patch against [2055]
trac_remove_version_check.patch (628 bytes ) - added by dmbrucker@… 14 years ago.
too obvious?

Download all attachments as: .zip

Change History (6)

by Bruce Christensen <trac@…>, 14 years ago

Attachment: emailnotify-r2055.patch added

Patch against [2055]

comment:1 by Christopher Lenz, 14 years ago

With 0.9, 2.2.2 is actually the lowest version of Python we support, so we should in fact remove the check completely.

comment:2 by Jonas Borgström, 14 years ago

#1953 marked as duplicate of this ticket

comment:3 by anonymous, 14 years ago

Cc: vyt@… added

by dmbrucker@…, 14 years ago

too obvious?

comment:4 by Christopher Lenz, 14 years ago

Resolution: fixed
Status: newclosed

Removed version check in [2216].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.