Edgewall Software
Modify

Opened 15 years ago

Closed 13 years ago

#1580 closed defect (duplicate)

Allow hiding ticket fields when submitting a new ticket

Reported by: orispammerpel at users.sourceforge.net Owned by: Alec Thomas
Priority: normal Milestone:
Component: ticket system Version: 0.8.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

When entering a new ticket, most fields are usually unnecessary.

This is especially when dealing with users outside the development project, who don't know Trac and may be confused by the different dropboxes. A simple ticket submission form could mean the difference between the user using the ticketing system or not.

It would be great if certain input could be hidden, perhaps in the new ticket URL, so we can provide links to submit tickets through.

For example:

  • Setting visible fields:
    http://www/trac/newticket?component=two&visible=summary,description
    
  • Setting hidden fields:
    http://www/trac/newticket?component=one&hidden=version,severity
    

Thanks!

Attachments (0)

Change History (7)

comment:1 by sid <sid.wiesner@…>, 13 years ago

Resolution: worksforme
Status: newclosed

This can be accomplished now with a plugin. Check out: http://trac-hacks.org/wiki/SimpleTicketPlugin

The full list of built-in properties you can hide is:

  • priority
  • milestone
  • component
  • severity
  • keywords
  • cc

comment:2 by Christian Boos, 13 years ago

One can still discuss whether Trac should do that by default or not (or have an option to do that by default), with the new WorkFlow. Any opinion on this, Alec?

comment:3 by Noah Kantrowitz (coderanger) <coderanger@…>, 13 years ago

+1 from me on having this as a base feature. SimpleTicket is pretty hackish anyway. It doesn't actually prevent someone from submitting those fields, it just hides them. I was pondering today that it might be nice try having per-field permissions in addition to the current ones, but thats straying towards the security branch.

comment:4 by Alec Thomas, 13 years ago

Resolution: worksforme
Status: closedreopened

The old WorkFlow code had the ability to suppress fields. This will definitely be in the latest incarnation. I might reopen this just as a reminder.

comment:5 by Alec Thomas, 13 years ago

Owner: changed from Jonas Borgström to Alec Thomas
Status: reopenednew

comment:6 by Christian Boos, 13 years ago

Milestone: 0.11

#1979 marked as duplicate of this one.

There's also possibly the idea that someone with the right credential might be able the see all the fields when creating a new ticket.

comment:7 by Christian Boos, 13 years ago

Milestone: 0.11
Resolution: duplicate
Status: newclosed

This could be achieved using conditional fields, see #2464.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Alec Thomas to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.