Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1581 closed defect (duplicate)

Changing the kind of status of a ticket

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8.1
Severity: trivial Keywords: workflow
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hello, please, is there any way to change the default status ('new', 'fixed', etc) or add a personalized status ? I am editing Trac for a portuguese language,and will be very useful for me to translate the status of the tickets. Thank you for the attention.

Attachments (0)

Change History (4)

comment:1 by Jeff Forcier (jeff [at] bitprophet [dot] org), 15 years ago

I don't know if there are any open tickets for implementing this in trac-admin or the Trac front-end, but there is a fairly simple way of doing it manually. It does require re-creating your Trac instances, however, although you could always edit an existing one with a SQLite client.

Edit the db_default.py file in your Trac install (e.g. your Python libraries folder → site-packages → trac → db_default.py). Near the top of this file is a fairly obviously laid out set of tuples which corresponds to the database schema; you'll see a section for the ticket statuses. Just edit to your heart's content (making sure to keep the indexes in order), and the next time you create a new Trac instance, it will reflect the changes you made.

I've done this on my system and it works fine.

comment:2 by Matthew Good, 15 years ago

Please do not edit the built-in "status" values. Currently Trac is not designed to support custom statuses, and it will cause Trac to function incorrectly if you change these values. Ticket #869 for creating custom workflows would help make this possible.

The "resolution" field is less critical and it may be possible to change these values, though this is still not recommended since there are still a few places that this may cause minor problems.

comment:3 by Christian Boos, 15 years ago

Keywords: workflow added

comment:4 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #869

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.