Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#1578 closed enhancement (duplicate)

a new method to manage the tags

Reported by: toliuch@… Owned by: Jonas Borgström
Priority: high Milestone:
Component: general Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I guess we need not copy anything to the 'tags' directory to record the special release. With trac, adding another table to write down it is a way to manage the releases. The new table would has two main fields: tag(or the name of the release) and its corresponding changeset/commit number. The tag field should be the primary key of the table. Also, some other fields would give us much help: comment to the release, path to check out the sources, the user name who created the release, data/time, etc.

Attachments (0)

Change History (4)

comment:1 by Matthew Good, 15 years ago

Resolution: duplicate
Status: newclosed

This is basically a duplicate of #959.

However, if Trac does add some features for release managment, it will be built around the Subversion tags, not as a way to replace them. For one thing it's not necessary for Trac to duplicate this functionality, and the tags are still important when interacting with the Subversion repository directly.

comment:2 by toliuch@…, 15 years ago

I do not think the svn system has any tag support. However, the commit ID is a very wonderful design to replace tag. To identify a release, just a tag(a simple string) is not enough. So, as a integrated SCM system, the ticket/issue tracking system should depend on a release management module.

comment:3 by Matthew Good, 15 years ago

Well, SVN doesn't support tags in a special manner like CVS does. In SVN they just appear as a directory under "/tags". However, there's more to a tag than just a revision number. You need to know the source of the tag, which could have been the trunk, or a branch, and in some cases a tag may not correspond directly to any single revision in your repository. Also, tags are important for someone looking directly at your SVN repository, so that they don't have to remember a specific revision number.

See http://svnbook.red-bean.com/en/1.0/ch04s06.html for more information on SVN's use of tags.

comment:4 by Matthew Good, 15 years ago

Milestone: 0.9

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.