Edgewall Software
Modify

#13202 closed defect (fixed)

Log TracLinks not enabled for AuthzSourcePolicy

Reported by: Ryan J Ollos Owned by: Jun Omae
Priority: normal Milestone: 1.0.19
Component: version control Version:
Severity: normal Keywords: AuthzSourcePolicy
Cc: Branch:
Release Notes:

Fixed log: TracLinks not enabled for AuthzSourcePolicy.

API Changes:
Internal Changes:

Description

The log TracLinks are disabled with the following AuthzSourcePolicy (reported in th:comment:2:ticket:13598:

[/]
* = r
@admins = rw

The following investigation was copied from th:comment:3:ticket:13598:

Attachments (0)

Change History (7)

comment:1 by anonymous, 13 months ago

Could be related to #11707.

comment:2 by Jun Omae, 13 months ago

It seems that the issue is introduced in #11972. The AuthzSourcePolicy doesn't handle repository realm, source:/tags/trac-1.2.5/trac/versioncontrol/svn_authz.py@:140-147#L113.

comment:3 by Jun Omae, 13 months ago

Proposed changes in [529bd8819/jomae.git].

Investigating, check_permission() expects source realm with path of the resource for LOG_VIEW action, e.g. source:/tags/trac-1.2.5/trac/versioncontrol/svn_authz.py@:146#L113. However, repository realm is passed in [14497] (#11972).

comment:4 by Ryan J Ollos, 13 months ago

Milestone: 1.0.201.0.19

comment:5 by Ryan J Ollos, 13 months ago

Changes look good to me.

comment:6 by Jun Omae, 13 months ago

Owner: set to Jun Omae
Status: newassigned

Thanks for the review. I push the changes soon.

comment:7 by Jun Omae, 13 months ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed in [17171] and merged in [17172-17174].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.