Edgewall Software
Modify

Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#13106 closed defect (duplicate)

OperationalError: (1052, "Column 'id' in where clause is ambiguous")

Reported by: hambardzum Owned by:
Priority: normal Milestone:
Component: query system Version: 1.2.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

While doing a GET operation on /query, Trac issued an internal error.

Request parameters:

{u'col': ['id',
          u'summary',
          u'status',
          u'reporter',
          u'owner',
          u'due_date',
          u'expected_completion_date',
          u'priority'],
 u'group': u'component',
 u'order': u'priority',
 u'report': u'7',
 u'status': [u'accepted', u'assigned', u'new', u'reopened']}

User agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

System Information

Trac 1.2.3
Babel 0.9.6
Genshi 0.7 (with speedups)
mod_wsgi 3.4 (WSGIProcessGroup WSGIApplicationGroup trac-new.instigate.local|/instigate)
MySQL server: "5.6.42", client: "5.6.42", thread-safe: 1
MySQLdb 1.2.5
Python 2.7.5 (default, Jul 13 2018, 13:06:57)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]
setuptools 0.9.8
Subversion 1.7.14 (r1542130)
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

AllAttachmentsMacro 0.2
DefaultCc 0.4dev
mail2trac 1.0
TicketValidator 0.2dev
TracAccountManager 0.4.4
TracAutocompleteUsersPlugin 0.4.4dev
TracAwesomeAttachments 0.4dev
TracCustomFieldAdmin 0.2.13
TracEstimationTools 0.5.0dev
TracIniAdmin 0.4
TracStats 0.6.1
TracSubTicketsPlugin 0.5.4dev
TracTicketTemplate 1.0dev
TracTocMacro 11.0.0.7
TracWysiwyg 0.12.0.7

Interface Customization

shared-htdocs
shared-templates
site-htdocs Old_instigatedesign.png, fetchmail, ins.png, instigate.png, instigatedesign.png, old_instigatedesign.png, site.js, style.css, theme.css
site-templates site.html

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 647, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 248, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 1016, in process_request
    return self.display_html(req, query)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 1122, in display_html
    tickets = query.execute(req, cached_ids=orig_list)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 303, in execute
    self.num_items = self._count(sql, args)
  File "build/bdist.linux-x86_64/egg/trac/ticket/query.py", line 284, in _count
    % sql, args)[0][0]
  File "build/bdist.linux-x86_64/egg/trac/db/api.py", line 122, in execute
    return db.execute(query, params)
  File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 128, in execute
    cursor.execute(query, params if params is not None else [])
  File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 72, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/cursors.py", line 205, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
OperationalError: (1052, "Column 'id' in where clause is ambiguous")

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 2 months ago

Component: report systemquery system
Resolution: duplicate
Status: newclosed

A duplicate of #13068.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.