Edgewall Software
Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#13107 closed defect (duplicate)

Changing the url when the request has not been completed causes an error in mod_wsgi - broken pipe.

Reported by: nwo Owned by:
Priority: normal Milestone:
Component: web frontend/mod_wsgi Version: 1.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Jun Omae)

I noticed that there is a problem with mod_wsgi on Apache Debian 9. When I click on changeset to some large commit of my svn repo and without waiting for the resulting page to appear, I click on some other link. This action generates an error that saves me to the logs:

Traceback (most recent call last):, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/home/trac/www/html/trac/cgi-bin/trac.wsgi", line 31, in application, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    return dispatch_request(environ, start_request), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 581, in dispatch_request, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    return _dispatch_request(req, env, env_error), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 620, in _dispatch_request, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    send_internal_error(env, req, sys.exc_info()), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 751, in send_internal_error, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    req.send_error(exc_info, status=500, env=env, data=data), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 732, in send_error, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    exc_info), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 613, in _dispatch_request, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    dispatcher.dispatch(req), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 274, in dispatch, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    req.send(output, content_type or 'text/html'), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 693, in send, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    self.write(content), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
  File "/usr/lib/python2.7/dist-packages/trac/web/api.py", line 833, in write, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
    self._write(''.join(buf)), referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunk
IOError: Apache/mod_wsgi failed to write response data: Broken pipe, referer: http://my_url/trac/myrepo/changeset/1865/myrepo/trunkrunk

Probably trac tries to answer the original request while I have already moved to the next page and there is no one to answer. I can of course ignore such errors in the log but I do not know if this is the proper operation of the application.

Attachments (0)

Change History (3)

comment:1 by Jun Omae, 7 months ago

Keywords: apache mod_wsgi broken pipe svn removed

A duplicate of #12650 (fixed in 1.2.1).

You can ignore the error because the client disconnect when sending the response.

comment:2 by Jun Omae, 7 months ago

Description: modified (diff)

comment:3 by Ryan J Ollos, 7 months ago

Resolution: duplicate
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.