Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

#12516 closed defect (cantfix)

TypeError: 'Logger' object is not callable

Reported by: pinklake Owned by:
Priority: normal Milestone:
Component: plugin/mercurial Version: 1.0.9
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /browser/repository, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': u'/repository'}

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

System Information

Trac 1.0.9
Babel 1.3
Docutils 0.12
Genshi 0.7 (with speedups)
Mercurial 3.7.3
Pygments 2.1
pysqlite 2.6.0
Python 2.7.11+ (default, Apr 17 2016, 14:00:29)
[GCC 5.3.1 20160413]
pytz 2014.10
setuptools 20.7.0
SQLite 3.11.0
jQuery 1.11.3
jQuery UI 1.10.1
jQuery Timepicker 1.2

Enabled Plugins

trac.about N/A
trac.admin.api N/A
trac.admin.console N/A
trac.admin.web-ui N/A
trac.attachment N/A
trac.cache N/A
trac.config N/A
trac.db.api N/A
trac.db.mysql-backend N/A
trac.db.postgres-backend N/A
trac.db.sqlite-backend N/A
trac.env N/A
trac.mimeview.api N/A
trac.mimeview.patch N/A
trac.mimeview.pygments N/A
trac.mimeview.rst N/A
trac.notification N/A
trac.perm N/A
trac.prefs.web-ui N/A
trac.resource N/A
trac.search.web-ui N/A
trac.ticket.admin N/A
trac.ticket.api N/A
trac.ticket.batch N/A
trac.ticket.default-workflow N/A
trac.ticket.model N/A
trac.ticket.notification N/A
trac.ticket.query N/A
trac.ticket.report N/A
trac.ticket.roadmap N/A
trac.ticket.web-ui N/A
trac.timeline.web-ui N/A
trac.versioncontrol.admin N/A
trac.versioncontrol.api N/A
trac.versioncontrol.svn-authz N/A
trac.versioncontrol.web-ui.browser N/A
trac.versioncontrol.web-ui.changeset N/A
trac.versioncontrol.web-ui.log N/A
trac.versioncontrol.web-ui.main N/A
trac.web.chrome N/A
trac.web.main N/A
trac.web.session N/A
trac.wiki.admin N/A
trac.wiki.api N/A
trac.wiki.intertrac N/A
trac.wiki.interwiki N/A
trac.wiki.macros N/A
trac.wiki.parser N/A
trac.wiki.web-api N/A
trac.wiki.web-ui N/A
TracAccountManager 0.4.3
TracMercurial 1.0.0.3dev-r0
tracopt.ticket.commit-updater N/A

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 554, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 247, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/web_ui/browser.py", line 423, in process_request
    quickjump_data = list(repos.get_quickjump_entries(rev))
  File "/usr/lib/python2.7/dist-packages/tracext/hg/backend.py", line 652, in get_quickjump_entries
    tagslist = self.repo.tagslist()
  File "/usr/lib/python2.7/dist-packages/mercurial/localrepo.py", line 783, in tagslist
    if not self._tagscache.tagslist:
  File "/usr/lib/python2.7/dist-packages/mercurial/util.py", line 723, in __get__
    result = self.func(obj)
  File "/usr/lib/python2.7/dist-packages/mercurial/localrepo.py", line 717, in _tagscache
    cache.tags, cache.tagtypes = self._findtags()
  File "/usr/lib/python2.7/dist-packages/mercurial/localrepo.py", line 754, in _findtags
    tagsmod.findglobaltags(self.ui, self, alltags, tagtypes)
  File "/usr/lib/python2.7/dist-packages/mercurial/tags.py", line 129, in findglobaltags
    _writetagcache(ui, repo, valid, alltags)
  File "/usr/lib/python2.7/dist-packages/mercurial/tags.py", line 381, in _writetagcache
    filename, len(cachetags))
TypeError: 'Logger' object is not callable

Attachments (0)

Change History (8)

comment:1 by pinklake, 4 years ago

This is after applying TracMercurial==1.0.0.7.dev0 following https://trac.edgewall.org/ticket/12258

comment:2 by Jun Omae, 4 years ago

Component: generalplugin/mercurial
Resolution: duplicate
Status: newclosed

A duplicate of #11696.

comment:3 by Jun Omae, 4 years ago

Resolution: duplicate
Status: closedreopened

Are you using mercurial-plugin@11269d75bbde? I'll confirm it with TracMercurial 1.0 branch and Mercurial 3.7.3…

comment:4 by Jun Omae, 4 years ago

That issue isn't reproduced in my environment. Your installed TracMercurial is not the latest of 1.0 branch. The following location in stack trace is not mercurial-plugin/tracext/hg/backend.py@11269d75bbde:659,672#L652.

  File "/usr/lib/python2.7/dist-packages/tracext/hg/backend.py", line 652, in get_quickjump_entries
    tagslist = self.repo.tagslist()

Please try the latest of TracMercurial 1.0 branch.

comment:5 by pinklake, 4 years ago

I've attempted to install again the latest version, although I am a noob.

I got here by:

hg clone https://hg.edgewall.org/trac/mercurial-plugin

and then from the python install i get:

creating 'dist/TracMercurial-1.0.0.7.dev0-py2.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing TracMercurial-1.0.0.7.dev0-py2.7.egg
Removing /usr/local/lib/python2.7/dist-packages/TracMercurial-1.0.0.7.dev0-py2.7.egg
Copying TracMercurial-1.0.0.7.dev0-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Removing TracMercurial 1.0.0.3dev-r0 from easy-install.pth file
TracMercurial 1.0.0.7.dev0 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.7/dist-packages/TracMercurial-1.0.0.7.dev0-py2.7.egg

??

comment:6 by Jun Omae, 4 years ago

It seems that you used TracMercurial 1.0.0.3dev (not the latest).

Removing TracMercurial 1.0.0.3dev-r0 from easy-install.pth file

Other points:

  • Please restart web server after upgrade plugins
    • You can confirm the version of used plugins in About Trac page
  • If you install TracMercurial package (e.g. ubuntu trac-mercurial), uninstall the package
    • /usr/lib/python2.7/dist-packages/tracext/hg/backend.py seems to be a file in the package
Last edited 4 years ago by Jun Omae (previous) (diff)

comment:7 by pinklake, 4 years ago

Fantastic!!

All working!!

Thanks heaps for your precious time, and sorry to burden you with what was a user/config issue.

comment:8 by Jun Omae, 4 years ago

Resolution: cantfix
Status: reopenedclosed

Thanks for the feedback. Closing as InstallationIssue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.