Replace Milestone.move_tickets with a static method of the Ticket class
|Reported by:||Ryan J Ollos||Owned by:|
The method performs table scope queries on the ticket table. It seems more appropriate therefore to deprecate
Milestone.move_tickets and replace it with a class method of the
Ticket class, such as
Ticket.set_milestone. We may want to consider what is an appropriate naming scheme for static class methods. So far, the only pattern I see is with the
select method: tags/trac-1.0.2/trac/ticket/model.py#L1133.