Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12094 closed defect (duplicate)

OperationalError: database is locked

Reported by: kristoffer.garmark@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /newticket, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'b7ffb6e77aa20345a02d7c88',
 'field_cc': u'',
 'field_checkbox_public': u'1',
 'field_description': u'Hello! We need help upgrading to 5#2 with all the latest patches# Is it something we can do by ourself and if yes can we send us any guidelines?\r\n\r\nRegards\r\nKristoffer',
 'field_reporter': u'kristoffer#garmark@securitas#com',
 'field_severity': u'normal',
 'field_summary': u'Help upgrading to 5#2',
 'field_type': u'enhancement',
 'submit': u'Create ticket'}

User agent: Mozilla/5#0 #compatible; MSIE 9#0; Windows NT 6#1; WOW64; Trident/5#0; SLCC2; #NET CLR 2#0#50727; #NET CLR 3#5#30729; #NET CLR 3#0#30729; Media Center PC 6#0; #NET4#0C; #NET4#0E#

System Information

Trac 0#12#2
Docutils 0#8#1
Genshi 0#6
Pygments 1#4
pysqlite 2#6#0
Python 2#7#3 #default, Feb 27 2014, 19:58:35# ##br## #GCC 4#6#3#
setuptools 7#0
SQLite 3#7#9
jQuery 1#4#2

Enabled Plugins

CustomerIntegration 1#0
FlexibleAssignTo 0#8#13
TracAccountManager 0#2#1dev-r4679

Python Traceback

Traceback #most recent call last#:
  File "/usr/local/lib/python2#7/dist-packages/Trac-0#12#2-py2#7#egg/trac/web/main#py", line 511, in _dispatch_request
    dispatcher#dispatch#req#
  File "/usr/local/lib/python2#7/dist-packages/Trac-0#12#2-py2#7#egg/trac/web/main#py", line 237, in dispatch
    resp = chosen_handler.process_request#req#
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 170, in process_request
    return self._process_newticket_request#req#
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 443, in _process_newticket_request
    self._do_create#req, ticket# # #redirected if successful#
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 1266, in _do_create
    ticket.insert##
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/model.py", line 233, in insert
    @self.env.with_transaction#db#
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/db/api.py", line 78, in transaction_wrapper
    ldb.commit##
OperationalError: database is locked

Attachments (0)

Change History (3)

comment:1 by Jun Omae, 5 years ago

Resolution: duplicate
Status: newclosed

Please stop it. #12061, #12070, #12071, #12072, #12081 and #12084 have been reported from the same environment. That is one of MostFrequentDuplicates. If rate of the issue is too high, we recommend to use PostgreSQL or MySQL rather than SQLite.

comment:2 by figaro, 5 years ago

Could this have to do with their hosting provider? I believe this to be http://www.tdchosting.dk/. If so, I can send them a message to upgrade their Trac environment.

comment:3 by Ryan J Ollos, 5 years ago

Last week I sent an email to everyone that had previously created a ticket (the reporters of the tickets listed in comment:1), repeating what Jun had said in the last several tickets, and suggested they use th:TracMigratePlugin to upgrade to MySQL or PostgreSQL. From th:#12366, it looks like they are at least attempting to do that, but they aren't communicating with their team about the need to stop creating tickets on t.e.o. I wouldn't bother contacting a hosting provider; the Trac instance is running modified source code, so they most certainly have at least a virtual private server rather than shared hosting, and the burden is on them to migrate their DatabaseBackend, or find someone they can pay to do that for them.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.