Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#12061 closed defect (duplicate)

OperationalError: database is locked

Reported by: musa.al-ghazali@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /ticket/3252, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'03ea9a6623f81d649b162b84',
 'action': u'leave',
 'cnum': u'3',
 'comment': u'It also happens in Infoblox? \r\nit is better if you check it all through!!',
 'field_cc': u'',
 'field_checkbox_public': u'1',
 'field_description': u"hi, \r\nwhen I will add Cisco repo's  i can not find them all.\r\nsee image.",
 'field_reporter': u'musa.al-ghazali@regionh.dk',
 'field_severity': u'normal',
 'field_summary': u'CIMT: Cisco repo.',
 'field_type': u'task',
 'id': u'3252',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2015-05-07 07:28:52.339457+00:00'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

System Information

Trac 0.12.2
Docutils 0.8.1
Genshi 0.6
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Feb 27 2014, 19:58:35)
[GCC 4.6.3]
setuptools 7.0
SQLite 3.7.9
jQuery 1.4.2

Enabled Plugins

CustomerIntegration 1.0
FlexibleAssignTo 0.8.13
TracAccountManager 0.2.1dev-r4679

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 169, in process_request
    return self._process_ticket_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 586, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/web_ui.py", line 1311, in _do_save
    cnum=internal_cnum):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/ticket/model.py", line 296, in save_changes
    @self.env.with_transaction(db)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/db/api.py", line 78, in transaction_wrapper
    ldb.commit()
OperationalError: database is locked

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 5 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #3446, one of MostFrequentDuplicates.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.