Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12035 closed defect (fixed)

Trac 1.1.5.dev0 - cannot add notifications

Reported by: lukasz.matecki@… Owned by: Jun Omae
Priority: normal Milestone: 1.1.5
Component: notification Version: 1.1.4
Severity: normal Keywords: preferences
Cc: Branch:
Release Notes:

Fix issues with Add button in notifications panel.

  • Add button not working when no subscription rules.
  • Label of added rule is empty on Internet Explorer.
API Changes:

Description (last modified by Jun Omae)

When I'm on the settings / notifications page, I cannot add any type of notification. When I press Add nothing happens. I'm logged in as TRAC_ADMIN user.

I have trachtmlnotification plugin enabled (if this has anything to do with it) and configured to sent html notification but I'm receiving text notifications instead.

See #12009 and th:#12158 (the bottom part and the screenshot). Although these are both fixed, my problem remains.

Attachments (0)

Change History (9)

comment:1 by Jun Omae, 5 years ago

Component: generalnotification
Description: modified (diff)
Keywords: notification removed
Version: 1.1dev

What browser are you using? Also, please check errors in your javascript console.

comment:2 by Jun Omae, 5 years ago

Description: modified (diff)
Keywords: preferences added

comment:3 by anonymous, 5 years ago

My browser version is Firefox 37.0.1

I'm getting the following from the browser JS console:

Metoda getPreventDefault() jest przestarzała.  Należy używać defaultPrevented.
(getPreventDefault() is obsolete, you should use defaultPrevented)

Thats all.

Note: I'm experiencing the same problem on IE 11.

comment:4 by Ryan J Ollos, 5 years ago

Did you deploy static assets and do a hard refresh of your browser after upgrading to 1.1.5?

in reply to:  4 comment:5 by anonymous, 5 years ago

Replying to rjollos:

Did you deploy static assets and do a hard refresh of your browser after upgrading to 1.1.5?

I don't think my server is using static resources; I'm using the built-in server like this:

c:\Python27\Scripts\tracd-script.py --http11 --hostname=localhost --port=8992 ^ ...

and I don't recall running the deploy command at all (don't see deploy foldery also in my environment).

Maybe it will be simpler for me to setup a test project and grant you access?

comment:6 by Jun Omae, 5 years ago

Milestone: 1.1.5
Owner: set to Jun Omae
Status: newassigned

Reproduced with new installation from [13985/trunk] on fresh virtualenv.

comment:7 by Jun Omae, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed
Version: 1.1dev1.1.4

This issue exists since 1.1.4.

Fixed in [13998]. Please try the latest. Thanks.

comment:8 by anonymous, 5 years ago

I've just installed r14003 and the notification settings can now be modified. One more question: I'm getting the html notifications as expected for the currently logged in user. But the smtp_always_cc user defined in trac.ini still receives plain text notifications (while using email_sender = HtmlNotificationSmtpEmailSender).

Any way to have this notification also formatted as html?

Regards.

in reply to:  8 comment:9 by Jun Omae, 5 years ago

Any way to have this notification also formatted as html?

Currently, no way to use text/html format for recipients defined in smtp_always_cc and smtp_always_bcc options. See #12036 and #11928.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.