Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12009 closed defect (duplicate)

trachtmlnotificationplugin 0.12.0.1 - text is sent instead of html

Reported by: lukasz.matecki@… Owned by:
Priority: normal Milestone:
Component: notification Version: 1.1.4
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I'm using trac 1.1.4 with trachtmlnotificationplugin 0.12.0.1.

Notifications are sent, but instead of html content I'm getting plain text.

From the log, it seems that the notification system decided to use plain text anyway:

20:17:17 Trac[api] DEBUG: Adding (None [0]) for 'always' on rule (AlwaysEmailSubscriber) for (email)
20:17:17 Trac[api] DEBUG: Adding (Adam [1]) for 'always' on rule (TicketOwnerSubscriber) for (email)
20:17:17 Trac[api] DEBUG: Adding (Lukasz [1]) for 'always' on rule (TicketUpdaterSubscriber) for (email)
20:17:17 Trac[mail] DEBUG: EmailDistributor has found the following formats capable of handling 'email' of 'ticket': text/html, text/plain
20:17:17 Trac[mail] DEBUG: EmailDistributor is sending event as 'text/plain' to: ----removed email----, ----removed email----, ----removed email----
20:17:17 Trac[mail] INFO: Sending notification through SMTP at smtp.gmail.com:587 to ['----removed email----', '----removed email----', '----removed email----']
20:17:18 Trac[web_ui] DEBUG: Side effect for ConfigurableTicketWorkflow

The configuration I use follows the instructions from http://trac-hacks.org/wiki/TracHtmlNotificationPlugin

[notification]
admit_domains = 
always_notify_owner = true
always_notify_reporter = true
always_notify_updater = true
ambiguous_char_width = single
batch_subject_template = $prefix Batch modify: $tickets_descr
email_sender = HtmlNotificationSmtpEmailSender
ignore_domains = 
mime_encoding = none
sendmail_path = 
smtp_always_bcc = 
smtp_always_cc = --- email ---
smtp_default_domain = 
smtp_enabled = true
use_tls = true
smtp_from_name = Viresco Trac Mailer
smtp_from = --- email ---
smtp_password = --- password ---
smtp_port = 587
smtp_server = smtp.gmail.com
smtp_user = --- user ---
smtp_replyto = --- email ---
smtp_subject_prefix = __default__
ticket_subject_template = $prefix #$ticket.id: $summary
use_public_cc = true
use_short_addr = false

Attachments (0)

Change History (2)

comment:1 by Ryan J Ollos, 7 years ago

Resolution: duplicate
Status: newclosed
Version: 1.1.4

Duplicate of #11927. You probably want to follow-up in th:#12158 now that #11927 is resolved.

comment:2 by Jun Omae, 7 years ago

The latest of th:TracHtmlNotificationPlugin works fine with Trac 1.1.4. If you want html mails, please configure text/html format in your preferences page.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.