Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12026 closed defect (duplicate)

OperationalError: database is locked

Reported by: karl.swanke Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

System Information

Trac 0.12.3
Trac 0.12.3
Babel 0.9.5
CustomFieldAdmin 0.2.5
Docutils 0.7
Genshi 0.6
GIT 1.8.4
mod_wsgi 2.5 (WSGIProcessGroup trac_wsgi_01 WSGIApplicationGroup %{GLOBAL})
Pygments 1.4dev-20110115
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
pytz 2008c
pytz 2008c
RPC 1.1.2
setuptools 0.6c12
setuptools 0.6c12
SQLite 3.7.3
Subversion 1.8.10 (r1615264)
jQuery 1.4.4

Enabled Plugins

BatchModify 0.8.0-trac0.12
SecureSession 0.10dev-r1500
TicketImport 0.8
TracAnnouncer 0.12.1.dev
TracCustomFieldAdmin 0.2.5
TracDownloads 0.3
TracGit 0.12.0.5dev
tracrpc.changeset N/A
TracXMLRPC 1.1.2
WorkflowEditorPlugin 1.0.4-r10056

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/auth.py", line 115, in process_request
    self._do_login(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/auth.py", line 153, in _do_login
    @self.env.with_transaction()
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/api.py", line 78, in transaction_wrapper
    ldb.commit()
OperationalError: database is locked

Attachments (0)

Change History (1)

comment:1 by Ryan J Ollos, 7 years ago

Resolution: duplicate
Status: newclosed

A duplicate of #3446, one of MostFrequentDuplicates.

If rate of the issue is too high, we recommend to use PostgreSQL or MySQL rather than SQLite.

(comment copied from comment:2:ticket:11738; this appears to be coming from the same Trac instance as the report in #11738.)

Last edited 7 years ago by Ryan J Ollos (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.