Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1157 closed defect (duplicate)

I think I may have deleted a component while a ticket was open and then saved that ticket window

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Oops…

Trac detected an internal error: unsubscriptable object

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide

Python traceback

Traceback (most recent call last):

File "/usr/lib/python2.3/site-packages/trac/core.py", line 525, in cgi_start

real_cgi_start()

File "/usr/lib/python2.3/site-packages/trac/core.py", line 520, in real_cgi_start

dispatch_request(path_info, args, req, env)

File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request

module.run()

File "/usr/lib/python2.3/site-packages/trac/Module.py", line 44, in run

self.render()

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 444, in render

self.save_changes (id)

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 372, in save_changes

when=now)

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 139, in save_changes

old_owner = cursor.fetchone()[0]

TypeError: unsubscriptable object

Attachments (0)

Change History (2)

comment:1 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #1045.

comment:2 by Christopher Lenz, 15 years ago

Component: generalticket system

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.