Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#1045 closed defect (fixed)

saving changes in ticket gives 'unsubscriptable object' error

Reported by: aadis Owned by: Jonas Borgström
Priority: high Milestone: 0.8.1
Component: ticket system Version: 0.8
Severity: critical Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

I'm trying to save changes to one particular ticket. Whenever I try to save any editing changes for only this ticket, I get the following:

Oops...
Trac detected an internal error:

unsubscriptable object

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/ModPythonHandler.py", line 194, in handler
    core.dispatch_request(mpr.path_info, args, mpr, env)
  File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/lib/python2.3/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 444, in render
    self.save_changes (id)
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 372, in save_changes
    when=now)
  File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 143, in save_changes
    self['owner'] = cursor.fetchone()[0]
TypeError: unsubscriptable object

I'm running trac 0.8 on Debian Sarge RC2, apache2 with mod_python support.

The particular ticket details are:

sqlite> select * from ticket where id=3;
3|1097681777|1097681777|dicom  server|normal|P2|nitin|tapesh|||0.90|0.90+|new||Implementation Version Name & Class ID should be changed|Dicoms saved by DicomServer should change the following two tags:
0002,0012,Implementation Class UID
0002,0013,Implementation Version Name

Nitin, lets discuss what should we change this to?

- Tapesh|
sqlite>

I can change the ticket details from the SQL backend.

Attachments (1)

1045.diff (1.2 KB ) - added by justus@… 15 years ago.
patch to close ticket

Download all attachments as: .zip

Change History (7)

comment:1 by jcline@…, 15 years ago

I am getting a similar error when trying to update a certain ticket. It looks like mine is looking for a previous owner that no longer exists…

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/core.py", line 525, in cgi_start
    real_cgi_start()
  File "/usr/local/lib/python2.4/site-packages/trac/core.py", line 520, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/local/lib/python2.4/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/local/lib/python2.4/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/local/lib/python2.4/site-packages/trac/Ticket.py", line 444, in render
    self.save_changes (id)
  File "/usr/local/lib/python2.4/site-packages/trac/Ticket.py", line 372, in save_changes
    when=now)
  File "/usr/local/lib/python2.4/site-packages/trac/Ticket.py", line 139, in save_changes
    old_owner = cursor.fetchone()[0]
TypeError: unsubscriptable object

comment:2 by Christopher Lenz, 15 years ago

Component: generalticket system
Milestone: 0.8.1
Priority: normalhigh
Severity: majorcritical

#1128 has been marked as duplicate of this ticket.

by justus@…, 15 years ago

Attachment: 1045.diff added

patch to close ticket

comment:3 by anonymous, 15 years ago

Resolution: fixed
Status: newclosed

comment:4 by anonymous, 15 years ago

Resolution: fixed
Status: closedreopened

comment:5 by Christopher Lenz, 15 years ago

#1149 and #1157 have been marked as duplicate of this ticket.

comment:6 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: reopenedclosed

Fixed in [1198], ported to 0.8 in [1199].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.