Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

#1149 closed defect (duplicate)

unscriptable object

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I have started getting this odd error when trying to update the description of a ticket. It onoy seems to happen to one ticket, and it started 'out of the blue', I made one succesful change and then every change after has resulted in ….

Oops...
Trac detected an internal error:

unsubscriptable object

Python traceback

Traceback (most recent call last):
  File "c:\python23\Lib\site-packages\trac\core.py", line 541, in cgi_start
    real_cgi_start()
  File "c:\python23\Lib\site-packages\trac\core.py", line 536, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "c:\python23\Lib\site-packages\trac\core.py", line 451, in dispatch_request
    module.run()
  File "c:\python23\Lib\site-packages\trac\Module.py", line 41, in run
    self.render()
  File "c:\python23\Lib\site-packages\trac\Ticket.py", line 456, in render
    self.save_changes (id)
  File "c:\python23\Lib\site-packages\trac\Ticket.py", line 378, in save_changes
    when=now)
  File "c:\python23\Lib\site-packages\trac\Ticket.py", line 143, in save_changes
    self['owner'] = cursor.fetchone()[0]
TypeError: unsubscriptable object

trac 1189, winXP, apache2

Attachments (0)

Change History (1)

comment:1 by Christopher Lenz, 17 years ago

Component: generalticket system
Resolution: duplicate
Status: newclosed

This is a duplicate of #1045.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.