Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1158 closed defect (fixed)

Null argument when running initenv

Reported by: rasheed.abdulaziz@… Owned by: daniel
Priority: normal Milestone: 0.9.3
Component: version control Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

I reviece the same error no matter what I try. Perhaps I am missing something? OS is XP Pro.

The process I follow is:


C:\Tools\Python\Scripts>python trac-admin c:\tracenv\trac1.db initenv
Creating a new Trac environment at c:\tracenv\trac1.db

Trac will first ask a few questions about your environment
in order to initalize and prepare the project database.

 Please enter the name of your project.
 This name will be used in page titles and descriptions.

Project Name [My Project]> Test

 Please specify the absolute path to the project Subversion repository.
 Repository must be local, and trac-admin requires read+write
 permission to initialize the Trac database.

Path to repository [/var/svn/test]> c:\TestRepo

 Please enter location of Trac page templates.
 Default is the location of the site-wide templates installed with Trac.

Templates directory [c:\Tools\Python\share\trac\templates]>
c:\TestRepo Repository access error: null argument to internal routine

Attachments (0)

Change History (9)

comment:1 by remco.boema@…, 15 years ago

Some problem here.

I'm on w2k, using the svn-win32-1.0.9_py bindings to trac, using a windows installer whenever possible. (apache2, svn, etc)

I've rebuilt my svn repository using berkley db instead of FSFS, and it seems that is the problem.

i've used '/' slashed paths when asked for paths by trac-admin initenv (except for the last one, the templates location)

It seems this works, as the program no longer crashes.

Hope this helps.

comment:2 by Christopher Lenz, 15 years ago

Description: modified (diff)
Resolution: invalid
Status: newclosed

You're probably using subversion 1.1.x, but the subversion python bindings for an earlier version (1.0.x). See this thread on the mailing list.

Please reopen if this is not the case.

comment:3 by anonymous, 14 years ago

Resolution: invalid
Status: closedreopened

comment:4 by anonymous, 14 years ago

Getting this problem relentlessly. Not doing anything wrong and I tried changing slashes to forward slashes on the repospath but that didn't work. Getting frustrated.

comment:5 by Matthew Good, 14 years ago

Resolution: invalid
Status: reopenedclosed

As cmlenz said above this is likely due to a mismatch in versions between the SVN applications and the bindings you've installed. If it's not, it still looks like an issue with your installation, so please ask on the MailingList or IrcChannel for support.

comment:6 by anonymous, 14 years ago

Same problem here, consistent subversion 1.2.3 on WinXP.

It's fixed if the subversion repository was created as a native filesystem, not berkeley db.

Not sure whose bug this is.

comment:7 by Christian Boos, 14 years ago

Milestone: 0.9.1
Resolution: invalid
Status: closedreopened

Can you try with the fix corresponding to r2461 applied?

comment:8 by Christopher Lenz, 14 years ago

Milestone: 0.9.10.9.2

comment:9 by Christian Boos, 14 years ago

Component: trac-adminversion control
Resolution: fixed
Status: reopenedclosed

I think r2461 will make the error reported in this ticket less likely to happen (at least, it did so for me). Ported to stable in r2710.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain daniel.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from daniel to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.