Edgewall Software
Modify

Opened 15 years ago

Closed 13 years ago

Last modified 3 years ago

#1091 closed defect (duplicate)

Permissions problem with NT domain login

Reported by: dgeene@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8
Severity: normal Keywords: ntlm
Cc: Branch:
Release Notes:
API Changes:

Description

I am using the NT Domain login for trac. (I have added the rights with double quotes: permission add "COMPUSENSE\dgeene" TRAC_ADMIN)

I can edit a wiki page when iam not logged in.

When i login iam not able to edit a page: the edit button is there but the page is not edited after pressing save changes and the new url ends with #preview.

When i logout again iam stil not able to change the wiki page. (again the url after pressing the 'save changes' button end with #preview)

Attachments (0)

Change History (7)

comment:1 by anonymous, 15 years ago

Component: generalwiki

comment:2 by anonymous, 15 years ago

Milestone: 0.8.1

comment:3 by Christopher Lenz, 15 years ago

Milestone: 0.8.1

Please read the mailing list thread Help: Trac Logon does not ask for my user name for some information on NTLM, especially this message. Of course, you might also get help by posting information about your specific problem to the mailing list.

A fix for this isn't going into 0.8.1 until either:

  • we know what exactly the problem is (and that it's not just a configuration problem) and how to fix it, or
  • a patch is provided.

comment:4 by Christopher Lenz, 15 years ago

Priority: highnormal
Severity: majornormal

comment:5 by Christopher Lenz, 15 years ago

Component: wikigeneral
Summary: Wiki page edit problemPermissions problem with NT domain login

comment:6 by Matthew Good, 13 years ago

Resolution: duplicate
Status: newclosed

This appears to be the same issue as #2795, which now has more information than this ticket. If you're using SSPI authentication see the notes about a possible fix on that ticket.

comment:7 by Peter Suter, 3 years ago

Keywords: ntlm added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.