Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#1090 closed defect (fixed)

Document required version of mod_python

Reported by: lol@… Owned by: Christopher Lenz
Priority: normal Milestone: 0.8.1
Component: web frontend/mod_python Version: 0.8
Severity: normal Keywords: documentation
Cc: Branch:
Release Notes:
API Changes:

Description

Whatever page I browse in my project, I get this message:

Trac detected an internal error:
 class FieldStorage has no attribute 'get'

Followed by the Python traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.2/site-packages/trac/ModPythonHandler.py", line 194, in handler
    core.dispatch_request(mpr.path_info, args, mpr, env)
  File "/usr/lib/python2.2/site-packages/trac/core.py", line 433, in dispatch_request
    module = module_factory(args, env, database, req)
  File "/usr/lib/python2.2/site-packages/trac/core.py", line 153, in module_factory
    mode = args.get('mode', 'wiki')
  File "/usr/lib/python2.2/site-packages/trac/ModPythonHandler.py", line 122, in get
    return util.FieldStorage.get(self, key, default)
AttributeError: class FieldStorage has no attribute 'get'

Environment is RedHat Enterprise Linux ES 3 and it is always reproductible.

Attachments (0)

Change History (6)

comment:1 by Jonas Borgström, 15 years ago

What mod_python version are you using?

I think you might need a newer version.

comment:2 by lol@…, 15 years ago

I use the stock one that came with the RHEL3: mod_python-3.0.3-3.ent It's not the latest, but not that old neither.

What min version should I use, there are no version info on wiki's TracModPython.

comment:3 by Jonas Borgström, 15 years ago

I think mod_python 3.1 is required but I'm not sure. And yes, it should be documented somewhere. Does upgrading to 3.1.x help?

comment:4 by lol@…, 15 years ago

Ok, I upgraded mod_python to the latest (3.1.3) from sources and it seems to be ok now. Thanks for your support and happy new year!

comment:5 by Christopher Lenz, 15 years ago

Component: generalmod_python frontend
Keywords: documentation added
Milestone: 0.8.1
Owner: changed from Jonas Borgström to Christopher Lenz
Summary: Ooops, internal error on all pagesDocument required version of mod_python

comment:6 by Christopher Lenz, 15 years ago

Resolution: fixed
Status: newclosed

Has been added in version version 12 of TracModPython.

(Looks like we require 3.1.3. I've never tried an earlier version myself.)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.