Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10471 closed defect (cantfix)

MissingOrInvalidScopeError: Invalid Sprint name: Sprint: 17 - 30 nov 2011

Reported by: simon.gronlund@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.2
Severity: normal Keywords:
Cc: support@…, leho@… Branch:
Release Notes:
API Changes:

Description

This error happens at the Agilo web GUI when selecting a sprint from the drop-downlist. A work-mate who is using Chrome does NOT have this issue and we are in the same team editing the same sprint. This is an issue either in TRAC or in Agilo.

Details: we have just finished the previous sprint and are now in the middle if the next sprint-planning meeting. We have not yet committed ourselves for any tasks but are adding and editing them.

We have not had this problem during the evaluation period, neither before enabling the Whiteboard or during the so called 30 day trial (which effectively was not 30 days but probably 28 days). I had no problems with adding and editing this new sprint, I can access it and edit it, but I cannot use the sprint-view, neither in white-board mode or list mode.

We bought and applied the license already a few days ago, this bug in Agilo was apparent from this morning, the previous sprint ended yesterday evening. As mentioned, this was NOT a problem in between previous sprints but now with the paid-for pro version.

Severity is "critical" because on several of our workstations we CANNOT USE this view right now, only one workmate using Chrome has no problems. All others are using FireFox on Linux.

Kindly Simon Gronlund Scrum Master simon.gronlund@…

PS: Should this ticket be filed against the wrong product, please forward it appropriately and notify me about those changes. DS.

How to Reproduce

While doing a GET operation on /backlog/Sprint Backlog, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'bscope': u'Sprint: 17 - 30 nov 2011',
 'name': u'Sprint Backlog',
 'scope': None,
 'view': u'View'}

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0

System Information

Trac 0.12.2
Agilo 1.3.4-PRO
Babel 0.9.5 (translations unavailable)
Genshi 0.6
MySQL server: "5.5.14", client: "5.5.14", thread-safe: 1
MySQLdb 1.2.3
Python 2.7.1 (r271:86832, Apr 12 2011, 16:16:18)
[GCC 4.6.0 20110331 (Red Hat 4.6.0-2)]
setuptools 0.6
Subversion 1.6.17 (r1128011)
jQuery 1.4.2

Enabled Plugins

binary-agilo 1.3.4-PRO
TracAccountManager 0.3.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/api/view.py", line 155, in process_request
    return self._call_filters_and_handler(req, handler)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/api/view.py", line 143, in _call_filters_and_handler
    data = handler(req) or {}
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/web_ui.py", line 313, in do_get
    backlog = self._get_backlog(req)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/web_ui.py", line 238, in _get_backlog
    return BacklogJSONView(self.env)._get_backlog(name=name, scope=scope)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/json_ui.py", line 49, in _get_backlog
    backlog = BacklogController(self.env).process_command(cmd_get)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/api/controller.py", line 361, in process_command
    return command.execute(self, date_converter, as_key)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/api/controller.py", line 315, in execute
    return self._execute(controller, date_converter, as_key)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/controller.py", line 56, in _execute
    scope=self.scope)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/model.py", line 571, in get
    return super(BacklogModelManager, self).get(**kwargs)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/core/model.py", line 1128, in get
    m = self.model(self.env, **kwargs)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/model.py", line 170, in __init__
    self._check_scope_is_valid(scope)
  File "/usr/lib/python2.7/site-packages/binary_agilo-1.3.4_PRO-py2.7.egg/agilo/scrum/backlog/model.py", line 185, in _check_scope_is_valid
    raise MissingOrInvalidScopeError("Invalid Sprint name: %s" % scope)
MissingOrInvalidScopeError: Invalid Sprint name: Sprint: 17 - 30 nov 2011

Attachments (0)

Change History (5)

comment:1 by Jun Omae, 8 years ago

Resolution: cantfix
Severity: criticalnormal
Status: newclosed

comment:2 by simon.gronlund@…, 8 years ago

Resolution: cantfix
Status: closedreopened

I am most surprised to find this ticket closed as can'tfix without further comment.

I speciifically asked for this issue to be forwarded and that we'd be notifed in this case.

Agilo-Pro is said to come with Professional Support, where did that go? Is our license fee a moot coin spent i vain?


Now, we continued to track down this issue because we found that this issue is in the Agilo software and how it handles values that are stored in the Trac database. We cannot say we have found your bug but this are our comments and suspicions: 1) We could access the Sprint via other panels which eventually had a plain link to the sprint. 2) The sprint-name had, for some reason, double white-space in its name. The plain link handled that properly. 3) The drop-down and View-button did not handle the double white-space properly, this was visible in the generated link read at the addess bar. 4) The database seems to store the value not-quoted which could possibly explain this, but there were other non-standard oddities in the database as well so this is uncertain.

Now we do not accept a close ticket but want you to kindly manage this issue, or to forward this issue properly

Notice that this issue is generated from the very link that was displayed in the error message. If that is wrong you'd better correct that message and direct the user properly.

Best regards Simon

comment:3 by Christian Boos, 8 years ago

Cc: support@… added
Resolution: cantfix
Status: reopenedclosed

Well, this is not Agilo-Pro here…

jomae hinted you at the support page for AgiloForScrum, where further contact details can be found, but usually we also CC: the Agilo people.

So closing as "cantfix" because indeed the faulty plugin is not maintained here and hence can't be fixed by us (the core Trac team). Hope this makes sense to you now ;-)

comment:4 by lkraav <leho@…>, 8 years ago

Cc: leho@… added

comment:5 by stefano.rago@…, 8 years ago

@cboos and @jomae: thanks for the CC @simon.gronlund: as I wrote in the email, we are investigating the issue. Thanks for your patience.

I don't think this is related to https://dev.agile42.com/ticket/1112 though both bugs do cause a similar error message.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.