Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9970 closed defect (duplicate)

mercurial-plugin filecontent unicode problem?

Reported by: ingo@… Owned by:
Priority: normal Milestone:
Component: plugin/mercurial Version: 0.12.1
Severity: normal Keywords: unicode mercurial-plugin mercurial plugin hg encoding
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Hi,

in my installation, the 'browse-source'-view of the content of a file, tracked by mercurial has problems displaying german letters like üäö. These letters are displayed correctly in hg commit-messages in the 'browse-source'-view and also by viewing the files with programs on the comandline.

i am using following combination of components: OS: Debian 5.0.7 (openvz kernel 2.6.18-194.26.1.el5.028stab079.2 x86_64 GNU/Linux) Python: 2.5.2 Trac: 0.12.1 Mercurial: 1.7.3 mercurial-plugin: 0.12.0.23dev_r9953-py2.5

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 10 years ago

Resolution: duplicate
Status: newclosed

Have you checked the value for the default_charset in TracIni#trac-section?

Duplicate of #7160.

comment:2 by anonymous, 10 years ago

That fixed the issue. I werent aware of the default_charset option. Thanks for your quick response.

comment:3 by Christian Boos, 10 years ago

Good! Thanks for the feedback.

That made me think it's probably time now to change the default (#8710).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.