Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#9901 closed defect (duplicate)

Anonymous users with the TICKET_APPEND permission granted will only see a single ticket action, namely leave as new

Reported by: Carsten Klein <carsten.klein@…> Owned by:
Priority: low Milestone:
Component: ticket system Version: 0.13dev
Severity: trivial Keywords:
Cc: carsten.klein@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Taking over from #8548

Replying to cboos:

Done in r8455.

In 0.13dev, when granting the anonymous user the permission TICKET_APPEND, they get the fieldset "action" under ticket modify, although it presents them with only one option → leave as new.

Since that option is a singular radio button, and since there are no other options available here, it would be nice to remove it from the presentation.

Attachments (1)

leaveasnew.png (8.5 KB ) - added by Carsten Klein <carsten.klein@…> 10 years ago.
Just one radio button

Download all attachments as: .zip

Change History (2)

by Carsten Klein <carsten.klein@…>, 10 years ago

Attachment: leaveasnew.png added

Just one radio button

comment:1 by Remy Blank, 10 years ago

Resolution: duplicate
Status: newclosed

I'll close this as a duplicate of #9510, which asks for removal of the "Actions" block when no action is present at all.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.