Edgewall Software
Modify

Opened 13 years ago

Last modified 2 years ago

#976 new enhancement

Wiki Page redirects to other Wiki pages and possibly other Trac resources

Reported by: Christian Boos Owned by:
Priority: lowest Milestone: next-major-releases
Component: wiki system Version: 0.11.2
Severity: minor Keywords: page alias, redirect
Cc: bfults+trac@…, kasper.souren+trac@…, felix.schwarz@…, yoav@…, Ryan J Ollos
Release Notes:
API Changes:

Description (last modified by Christian Boos)

There should be a way to redirect from a wiki page to another Wiki page. A [[Redirect(target)]] macro could do that. The target could actually be any Trac resource, if specified by a TracLink.

That could be handy in several situations:

It could be useful to implement this in Trac core instead of a plugin so that one provide a generic way to detect that one was redirected, and eventually provide a Edit button that would trigger the edition of the originally requested page (the one containing the [[Redirect]] macro or the #redirect directive, or whatever is chosen to implement it…)

Attachments (0)

Change History (28)

comment:1 Changed 13 years ago by vittorio

Severity: normalenhancement

comment:2 Changed 13 years ago by utopiste

Resolution: wontfix
Status: newclosed

This idea is well… a bad idea. It's a big hack solution for a not real problem.
The easy way for worked with a lot of ticket that i use is :

  • Use a real browser, use firefox
  • Go to the report : My Tickets
  • Click on the RSS Feed icon in the status bar
  • Add this bookmark on your links toolbar
  • You have now a realtime list of your ticket with #ticketnumber - description

If you want realy have wiki page that redirect you add yourself a #html markup block and create some javacript that redirect you to the good page.

comment:3 Changed 13 years ago by anonymous

Not to argue in favor of textual aliases, but… it is really posible to put JavaScript code in a #!html markup block? I though script was among the forbidden tags in such blocks.

comment:4 Changed 13 years ago by haui at haumacher.de

Keywords: page alias redirect added; aliases removed
Resolution: wontfix
Status: closedreopened

The workaround suggested by "utopiste" is well… simply wrong. Embedding script into wiki pages is disallowed (which is not a bug, but a feature). But having alias names for pages would be really useful, not only for the purpose mentioned in this ticket. Another solution would be to have a redirect macro (like in Wikipedia). But anyway, there must be some support to be able to edit redirecting pages (something like a do-not-redirect argument).

The following error message is printed, if you try to embedd script code into your page:

Error: HTML block contains disallowed tags.

<script>
document.location="where-ever";
</script>

comment:5 Changed 13 years ago by haui at haumacher.de

Summary: [ER] Textual aliases for Tickets (and for any other Trac object)Page redirects and textual aliases for Tickets (and other Trac objects)

comment:6 Changed 13 years ago by haui at haumacher.de

Here is a (partial) solution. Use the redirect macro from:

wiki:MacroBazaar:redirect.py

Further descriton can be found at the MacroBazaar. Editing redirecting pages is somewhat hacky.

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:7 Changed 12 years ago by anonymous

Sorry to say that, but the redirect macro doesn't seem to work w/ 0.9 (at least not w/ beta2).

comment:8 Changed 12 years ago by moschny at ipd dot uni-karlsruhe dot de

There is an updated version available on our website that should work with 0.9b2.

See http://svn.ipd.uni-karlsruhe.de/trac/javaparty/wiki/TracRedirect .

comment:9 Changed 12 years ago by Alec Thomas

Addressing only the textual aliases part of this, wouldn't this be achievable with a custom alias text field? Perhaps group? This would let you group all related tickets using a query.

comment:10 Changed 12 years ago by Christian Boos

Owner: changed from Jonas Borgström to Christian Boos
Status: reopenednew

Grouping tickets is something I currently do using the keywords field, e.g workflow tickets.

There are other ideas that have been discussed for achieving this:

  • Master tickets (#886)
  • Relations/tags (cf. TracCrossReferences).
    An alias text field could actually be used for creating an <<alias>> relation to a wiki page.

comment:11 Changed 11 years ago by Christian Boos

Description: modified (diff)
Summary: Page redirects and textual aliases for Tickets (and other Trac objects)Wiki Page redirects to other Wiki pages and possibly other Trac resources

#3604 was marked as duplicate of this one. Also the description has been rewritten to reflect my current ideas about this feature.

comment:12 Changed 11 years ago by Christian Boos

Milestone: 1.0

Eventually one day… MoinMoin has this feature for example. Also, this would provide a cheap way to "fix the links" after a WikiRename ;)

comment:13 Changed 10 years ago by bfults+trac@…

Cc: bfults+trac@… added

MediaWiki accomplishes both the redirect feature and ability to edit a redirect pretty cleanly. This would be a huge help in Trac.

comment:14 Changed 10 years ago by anonymous

Cc: kasper.souren+trac@… added

I would really love to have this feature in the standard release. MediaWiki style. It's almost pushing me into Trac hacking.

comment:15 in reply to:  14 Changed 9 years ago by TomDesp

Version: 0.80.11.2

Replying to anonymous:

I would really love to have this feature in the standard release. MediaWiki style. It's almost pushing me into Trac hacking.

Pretty much the same for me. A-la MediaWiki redirections (that is aliases) is a must have in wiki platforms. It makes content more consistent, readable and easy to maintain.

comment:16 Changed 9 years ago by TomDesp

Another point: redirection has to be handled server side, not client side, to keep track of redirected backlinks. Also not to be javascript enabling dependent…

comment:17 Changed 8 years ago by Felix Schwarz <felix.schwarz@…>

Cc: felix.schwarz@… added

comment:18 Changed 8 years ago by yoav@…

Cc: yoav@… added

I want MediaWiki style redirects. This feature is really missing for me too.

comment:19 Changed 8 years ago by Christian Boos

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:20 Changed 8 years ago by Christian Boos

Milestone: triagingnext-major-0.1X
Priority: normallowest
Severity: normalminor

comment:21 Changed 7 years ago by Martin Scharrer <martin@…>

The plugins TracRedirect and ServerSideRedirectPlugin provide this functionality. The syntax [[Redirect(realm:id)]] is supported by the ServerSideRedirectPlugin.

comment:22 in reply to:  21 ; Changed 7 years ago by Steffen Hoffmann

Replying to Martin Scharrer <martin@…>:

The plugins TracRedirect and ServerSideRedirectPlugin provide this functionality. The syntax [[Redirect(realm:id)]] is supported by the ServerSideRedirectPlugin.

ServerSideRedirectPlugin includes TracRedirect functionality in a smart way, is very fast and all-in-all the best solution for redirections in Trac. +1 from me to make it a Trac standard macro.

comment:23 Changed 3 years ago by Ryan J Ollos

Cc: Ryan J Ollos added

comment:24 in reply to:  22 Changed 3 years ago by Ryan J Ollos

Replying to shoffmann:

ServerSideRedirectPlugin includes TracRedirect functionality in a smart way, is very fast and all-in-all the best solution for redirections in Trac. +1 from me to make it a Trac standard macro.

Recent discussion about this in gmessage:trac-dev:nkMUY_8ILF0/iEUDhXSWAosJ.

Seems like a good project would be to review the code and, if suitable, prepare the macro for integration to the Trac core. Maybe someone is interested in doing that? :)

Last edited 3 years ago by Ryan J Ollos (previous) (diff)

comment:25 Changed 2 years ago by Ryan J Ollos

Owner: Christian Boos deleted

comment:26 Changed 2 years ago by Ryan J Ollos

I looked at ServerSideRedirectPlugin. We could following the same pattern - in WikiModule.process_request, parse the page text to match the macro, extract the TracLink and redirect. It's a fine workaround for ServerSideRedirectPlugin, but it doesn't seem very elegant for the Trac codebase.

Instead we could add a dedicated field to the WikiPage model and form. When the field is non-empty, attempt to redirect to the specified resource or URL. Would that be better?

comment:27 Changed 2 years ago by Ryan J Ollos

Reporter: changed from cboos@… to Christian Boos

comment:28 Changed 2 years ago by Ryan J Ollos

The wiki pragmas idea in #3307 could be applicable here.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.