Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#958 closed defect (worksforme)

Roadmap module doesn't pick up re-opened tickets

Reported by: john at pagonis dot org Owned by: Christopher Lenz
Priority: high Milestone:
Component: roadmap Version: 0.8
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Apparently if a ticket is re-opened for some reason, there is no option for someone to 're-accept' it; which is fine.

Unfortunately, the reporting used by the Roadmap module misses this, thus reopened tickets do not form part of the Roadmap. As a result the Roadmap bar and the active/closed stats do not include this re-opened ticket, hence giving a misleading indication of the project's state.

To test this, simply re-open a closed ticket.

Attachments (0)

Change History (5)

comment:1 by anonymous, 16 years ago

btw can you scramble my email as it may be fished by spam-agents ;-(

comment:2 by Christopher Lenz, 16 years ago

Reporter: changed from john@… to john at pagonis.org

comment:3 by Christopher Lenz, 16 years ago

Reporter: changed from john at pagonis.org to john at pagonis dot org
Resolution: worksforme
Status: newclosed

This works for me.

For example:

  • I go to the roadmap/milestone page, click on the number of active tickets.
  • Close one of the tickets.
  • Go back to the roadmap/milestone page. Observe: the ticket has moved to the closed tickets count.
  • Go back to the ticket and reopen it.
  • Go to the roadmap/milestone page and observe that the ticket has moved back to the active tickets count.

Please reopen this ticket if I have misunderstood you.

comment:4 by anonymous, 16 years ago

Resolution: worksforme
Status: closedreopened

I can reliably reproduce this every time. But the ticket was created and closed with 0.7.x. After the upgrade the ticket was reopened. That is when the problem was observed.

It may just work fine only if the ticket was orifinaly created with 0.8 ;-( I tried this on 0.8 tickets and it behaves as you describe. on 0.7 migrated tickets it doesn't.

comment:5 by anonymous, 16 years ago

Resolution: worksforme
Status: reopenedclosed

Works for me now. It was down to a bad component naming discrepancy on the fields (component naming was xyz-1 vs xyz 1.0 that the old ticket was opened on).

sorry for the trouble[[BR}}

and btw that was very swift response ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.