Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#9555 closed defect (duplicate)

RuntimeError: instance.__dict__ not accessible in restricted mode

Reported by: magenik_ocean@… Owned by:
Priority: normal Milestone:
Component: project Version: 0.12
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET CLR 4.0.20506)

System Information

Trac 0.12
Genshi 0.6
mod_wsgi 2.5 (WSGIProcessGroup WSGIApplicationGroup assembla.aion-dev.com|/aion-dev)
pysqlite 2.6.0
Python 2.4.3 (#1, Sep 3 2009, 15:37:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c9
SQLite 3.7.0
Subversion 1.6.12 (r955767)
jQuery 1.4.2

Enabled Plugins

TracAccountManager 0.2.1dev-r0

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 513, in _dispatch_request
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 200, in dispatch
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 346, in _pre_process_request
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 330, in pre_process_request
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/api.py", line 526, in get_repository
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/svn_fs.py", line 302, in get_repository
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/svn_fs.py", line 316, in __init__
  File "build/bdist.linux-x86_64/egg/trac/versioncontrol/svn_fs.py", line 152, in __init__
  File "/usr/local/lib/svn-python/svn/core.py", line 241, in svn_pool_create
    return Pool(parent_pool)
  File "/usr/local/lib/svn-python/libsvn/core.py", line 1555, in svn_pool_create
    return apply(_core.svn_pool_create, args)
  File "/usr/local/lib/svn-python/libsvn/core.py", line 5738, in _wrap
    obj.set_parent_pool(self)
  File "/usr/local/lib/svn-python/libsvn/core.py", line 5651, in set_parent_pool
    self._parent_pool = parent_pool or application_pool
  File "/usr/local/lib/svn-python/libsvn/core.py", line 5639, in <lambda>
    __setattr__ = lambda self, name, value: _swig_setattr(self, apr_pool_t, name, value)
  File "/usr/local/lib/svn-python/libsvn/core.py", line 24, in _swig_setattr
    return _swig_setattr_nondynamic(self,class_type,name,value,0)
  File "/usr/local/lib/svn-python/libsvn/core.py", line 19, in _swig_setattr_nondynamic
    self.__dict__[name] = value
RuntimeError: instance.__dict__ not accessible in restricted mode

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 10 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3371 (and one of our MostFrequentDuplicates).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.